Eric Blake <address@hidden> writes:
On 03/03/2015 12:15 AM, zhanghailiang wrote:
Yes, this is the reason ..., agreed, i don't like the abbreviate,
But there is already a 'MigrationState' type defined:
So, what about MigrationStatus ? ;)
That would be fine with me.
Bad news, this name has also been used :(
typedef struct MigrationStatus
You know, you could always rename the internal-only conflict into
something else so that the publicly exported typename is nice. Yeah,
that makes the series longer,
by *two* patch hunks updating the four occurences of MigrationStatus,
but it should be all mechanical
conversions, right? I'm not going to be too picky about what color we
paint this bikeshed, though.
Me neither, but we shouldn't compromise on external interfaces just to
avoid a bit of internal churn. Pick a good name, then do what it takes.