qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH v7 0/5] pc: acpi: various fixes and cleanups


From: Igor Mammedov
Subject: [Qemu-devel] [PATCH v7 0/5] pc: acpi: various fixes and cleanups
Date: Fri, 30 Jan 2015 13:29:35 +0000

NOTE to maintainer: please update test data (ACPI blobs) in test cases

changes from v6:
 * drop "[PATCH v6 1/5] pc: acpi-build: cleanup AcpiPmInfo initialization"
 * fixup and cleanup build_append_namestring patch as Michael requested
 * add extra patch based on "acpi-build: skip hotplugged bridges"
   http://lists.gnu.org/archive/html/qemu-devel/2015-01/msg04085.html
   which applies on top of this series

changes from v5:
 * fix codding style issue with var names
 * fix Copyright from 2014 to 2015
 * rename acpi-build-utils.[ch] to aml-build.[ch]

changes from v4:
 * rebased on top of PCI tree, dropping 2 patches
   that are already there

changes from v3:
 * rename acpi_gen_utils.[ch] to acpi-build-utils.[ch]
 * copy GLP license block from acpi-build.c
 * assert on wrong Segcount earlier and extend condition to
   seg_count > 0 && seg_count <= 255
 * drop "pc: acpi: decribe bridge device as not hotpluggable"
 * keep original logic of creating bridge devices as it was done
   in 133a2da48 "pc: acpi: generate AML only for PCI0 ..."
 * if bus is non hotpluggable, add child slots to bus as non
   hotpluggable as it was done in original code.

changes from v2:
 * codding style fixups
 * check for SegCount earlier
 * use hotpluggable device object instead of not hotpluggable
    for non present devices, and add it only when bus itself is
    hotpluggable

changes from v1:
 * drop: [PATCH 7/9] acpi: replace opencoded notify codes with named values
 * use Michael's suggestion to improve build_append_nameseg()
 * drop long scope names and go back to recursion,
   but still significantly simplify building of PCI tree

this series is an attempt to shave off a bunch of
not directly related patches from already big dynamic
AML series (although it's dependency for it)

Tested: on XPsp3 to WS2012R2 and REHL6/7 guests.

Git tree for testing:
 https://github.com/imammedo/qemu/commits/acpi_pci_gen_simplification_v7



Igor Mammedov (5):
  acpi: move generic aml building helpers into dedictated file
  acpi: add build_append_namestring() helper
  acpi: drop min-bytes in build_package()
  pc: acpi-build: simplify PCI bus tree generation
  acpi-build: skip hotplugged bridges

 hw/acpi/Makefile.objs       |   1 +
 hw/acpi/aml-build.c         | 259 +++++++++++++++++++++++++
 hw/i386/acpi-build.c        | 456 ++++++++++----------------------------------
 include/hw/acpi/aml-build.h |  23 +++
 4 files changed, 380 insertions(+), 359 deletions(-)
 create mode 100644 hw/acpi/aml-build.c
 create mode 100644 include/hw/acpi/aml-build.h

-- 
1.8.3.1




reply via email to

[Prev in Thread] Current Thread [Next in Thread]