qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2 08/21] qcow2: More helpers for refcount modif


From: Max Reitz
Subject: Re: [Qemu-devel] [PATCH v2 08/21] qcow2: More helpers for refcount modification
Date: Mon, 17 Nov 2014 09:44:07 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.2.0

On 2014-11-15 at 18:08, Eric Blake wrote:
On 11/14/2014 06:06 AM, Max Reitz wrote:
Add helper functions for getting and setting refcounts in a refcount
array for any possible refcount order, and choose the correct one during
refcount initialization.

Signed-off-by: Max Reitz <address@hidden>
---
  block/qcow2-refcount.c | 146 ++++++++++++++++++++++++++++++++++++++++++++++++-
  1 file changed, 144 insertions(+), 2 deletions(-)

+static void get_refcount_functions(int refcount_order,
+                                   Qcow2GetRefcountFunc **get,
+                                   Qcow2SetRefcountFunc **set)
+{
+    switch (refcount_order) {
+        case 0:
+            *get = &get_refcount_ro0;
+            *set = &set_refcount_ro0;
+            break;
Bike-shedding: instead of a switch statement and open-coded assignments,
is it worth setting up an array of function pointers where you just grab
the correct functions by doing array[refcount_order]?  But I don't see
any strong reason to change style; what you have works.

I thought about it, but it wouldn't get much shorter. But maybe it looks nicer. I ought to think about it again.

Max

Reviewed-by: Eric Blake <address@hidden>




reply via email to

[Prev in Thread] Current Thread [Next in Thread]