[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] slirp-smb broken with Samba 4.1

From: Peter Wu
Subject: Re: [Qemu-devel] slirp-smb broken with Samba 4.1
Date: Mon, 03 Nov 2014 13:22:19 +0100
User-agent: KMail/4.13.3 (Linux/3.17.0-rc4-custom-00168-g7ec62d4; KDE/4.14.2; x86_64; ; )


On Friday 24 October 2014 18:55:07 Jan Kiszka wrote:
> writing to you as you provided a fix for the last related issue:
> I just noticed that the samba-based share is broken again with smbd
> version 4.1.11. Tried to look briefly at it, realized that it is a
> permission thing (different error when qemu runs as root) but also some
> more nasty problem with configuring r/w guest access to a share. If you
> have experience in that area, maybe you have an idea.

It appears that the issue is solved in Samba 4.2 (tested with
samba-4.2.0rc1-388-ga3b333a). Using that samba version fixes the problem, I'll
try to do a bisect to see where it got fixed in Samba.

As an aside, would it be possible to override the samba binary at runtime,
without compiling? Either an envvar (SMBD) or an option (-net

Kind regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]