[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH V6 7/8] cpu-hotplug: rename function for better read
From: |
Gu Zheng |
Subject: |
[Qemu-devel] [PATCH V6 7/8] cpu-hotplug: rename function for better readability |
Date: |
Wed, 22 Oct 2014 11:24:31 +0800 |
Rename:
AcpiCpuHotplug_init --> acpi_cpu_hotplug_init
AcpiCpuHotplug_ops --> acpi_cpu_hotplug_ops
for better readability, just cleanup.
Reviewed-by: Igor Mammedov <address@hidden>
Signed-off-by: Gu Zheng <address@hidden>
---
hw/acpi/cpu_hotplug.c | 4 ++--
hw/acpi/ich9.c | 4 ++--
hw/acpi/piix4.c | 4 ++--
include/hw/acpi/cpu_hotplug.h | 4 ++--
4 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/hw/acpi/cpu_hotplug.c b/hw/acpi/cpu_hotplug.c
index b69b16c..ae48b63 100644
--- a/hw/acpi/cpu_hotplug.c
+++ b/hw/acpi/cpu_hotplug.c
@@ -55,8 +55,8 @@ void acpi_cpu_plug_cb(ACPIREGS *ar, qemu_irq irq,
acpi_update_sci(ar, irq);
}
-void AcpiCpuHotplug_init(MemoryRegion *parent, Object *owner,
- AcpiCpuHotplug *gpe_cpu, uint16_t base)
+void acpi_cpu_hotplug_init(MemoryRegion *parent, Object *owner,
+ AcpiCpuHotplug *gpe_cpu, uint16_t base)
{
CPUState *cpu;
diff --git a/hw/acpi/ich9.c b/hw/acpi/ich9.c
index 7585364..ea991a3 100644
--- a/hw/acpi/ich9.c
+++ b/hw/acpi/ich9.c
@@ -235,8 +235,8 @@ void ich9_pm_init(PCIDevice *lpc_pci, ICH9LPCPMRegs *pm,
pm->powerdown_notifier.notify = pm_powerdown_req;
qemu_register_powerdown_notifier(&pm->powerdown_notifier);
- AcpiCpuHotplug_init(pci_address_space_io(lpc_pci), OBJECT(lpc_pci),
- &pm->gpe_cpu, ICH9_CPU_HOTPLUG_IO_BASE);
+ acpi_cpu_hotplug_init(pci_address_space_io(lpc_pci), OBJECT(lpc_pci),
+ &pm->gpe_cpu, ICH9_CPU_HOTPLUG_IO_BASE);
if (pm->acpi_memory_hotplug.is_enabled) {
acpi_memory_hotplug_init(pci_address_space_io(lpc_pci),
OBJECT(lpc_pci),
diff --git a/hw/acpi/piix4.c b/hw/acpi/piix4.c
index 8320b18..8fde808 100644
--- a/hw/acpi/piix4.c
+++ b/hw/acpi/piix4.c
@@ -555,8 +555,8 @@ static void piix4_acpi_system_hot_add_init(MemoryRegion
*parent,
acpi_pcihp_init(&s->acpi_pci_hotplug, bus, parent,
s->use_acpi_pci_hotplug);
- AcpiCpuHotplug_init(parent, OBJECT(s), &s->gpe_cpu,
- PIIX4_CPU_HOTPLUG_IO_BASE);
+ acpi_cpu_hotplug_init(parent, OBJECT(s), &s->gpe_cpu,
+ PIIX4_CPU_HOTPLUG_IO_BASE);
if (s->acpi_memory_hotplug.is_enabled) {
acpi_memory_hotplug_init(parent, OBJECT(s), &s->acpi_memory_hotplug);
diff --git a/include/hw/acpi/cpu_hotplug.h b/include/hw/acpi/cpu_hotplug.h
index 4657e71..f6d358d 100644
--- a/include/hw/acpi/cpu_hotplug.h
+++ b/include/hw/acpi/cpu_hotplug.h
@@ -23,6 +23,6 @@ typedef struct AcpiCpuHotplug {
void acpi_cpu_plug_cb(ACPIREGS *ar, qemu_irq irq,
AcpiCpuHotplug *g, DeviceState *dev, Error **errp);
-void AcpiCpuHotplug_init(MemoryRegion *parent, Object *owner,
- AcpiCpuHotplug *gpe_cpu, uint16_t base);
+void acpi_cpu_hotplug_init(MemoryRegion *parent, Object *owner,
+ AcpiCpuHotplug *gpe_cpu, uint16_t base);
#endif
--
1.7.7
- [Qemu-devel] [PATCH V6 0/8] cpu/acpi: convert cpu hot plug to hotplug_handler API, Gu Zheng, 2014/10/21
- [Qemu-devel] [PATCH V6 1/8] acpi/cpu: add cpu hotplug callback function to match hotplug_handler API, Gu Zheng, 2014/10/21
- [Qemu-devel] [PATCH V6 2/8] acpi:ich9: convert cpu hotplug to hotplug_handler API, Gu Zheng, 2014/10/21
- [Qemu-devel] [PATCH V6 3/8] acpi:piix4: convert cpu hotplug to hotplug_handler API, Gu Zheng, 2014/10/21
- [Qemu-devel] [PATCH V6 4/8] pc: add cpu hotplug handler to PC_MACHINE, Gu Zheng, 2014/10/21
- [Qemu-devel] [PATCH V6 5/8] pc: Update rtc_cmos in pc_cpu_plug, Gu Zheng, 2014/10/21
- [Qemu-devel] [PATCH V6 6/8] qom/cpu: remove the unused CPU hot-plug notifier, Gu Zheng, 2014/10/21
- [Qemu-devel] [PATCH V6 7/8] cpu-hotplug: rename function for better readability,
Gu Zheng <=
- [Qemu-devel] [PATCH V6 8/8] acpi/cpu-hotplug: introduce helper function to keep bit setting in one place, Gu Zheng, 2014/10/21
- Re: [Qemu-devel] [PATCH V6 0/8] cpu/acpi: convert cpu hot plug to hotplug_handler API, Gu Zheng, 2014/10/24