qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v5 04/33] target-arm: rename arm_current_pl to a


From: Greg Bellows
Subject: Re: [Qemu-devel] [PATCH v5 04/33] target-arm: rename arm_current_pl to arm_current_el
Date: Mon, 6 Oct 2014 14:55:29 -0500



On 6 October 2014 10:10, Peter Maydell <address@hidden> wrote:
On 30 September 2014 22:49, Greg Bellows <address@hidden> wrote:
> Renamed the arm_current_pl CPU function to more accurately represent that it
> returns the ARMv8 EL rather than ARMv7 PL.

Comment added in v6.
 
>
> Signed-off-by: Greg Bellows <address@hidden>
> ---
>  target-arm/cpu.h           | 18 +++++++++---------
>  target-arm/helper-a64.c    |  6 +++---
>  target-arm/helper.c        | 22 +++++++++++-----------
>  target-arm/internals.h     |  2 +-
>  target-arm/op_helper.c     | 16 ++++++++--------
>  target-arm/translate-a64.c |  2 +-
>  target-arm/translate.c     |  2 +-
>  7 files changed, 34 insertions(+), 34 deletions(-)
>
> diff --git a/target-arm/cpu.h b/target-arm/cpu.h
> index 10afef0..101d139 100644
> --- a/target-arm/cpu.h
> +++ b/target-arm/cpu.h
> @@ -982,7 +982,7 @@ static inline bool cptype_valid(int cptype)
>  #define PL1_RW (PL1_R | PL1_W)
>  #define PL0_RW (PL0_R | PL0_W)
>
> -static inline int arm_current_pl(CPUARMState *env)
> +static inline int arm_current_el(CPUARMState *env)

I suggest we add a brief comment before the function:
/* Return the current Exception Level (as per ARMv8;
 * note that this differs from the ARMv7 Privilege Level).
 */

You should also fix the "PL2" and "PL3" references in
the comments to read "EL2" and "EL3".


Fixed in v6.
 
thanks
-- PMM


reply via email to

[Prev in Thread] Current Thread [Next in Thread]