[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PULL 08/10] vga: Rename vga_template.h to vga-helpers.h
From: |
Gerd Hoffmann |
Subject: |
[Qemu-devel] [PULL 08/10] vga: Rename vga_template.h to vga-helpers.h |
Date: |
Thu, 2 Oct 2014 09:44:31 +0200 |
From: Benjamin Herrenschmidt <address@hidden>
It's no longer a template, we only instanciate the file once.
Keep it a #included file so the functions remain static.
Signed-off-by: Benjamin Herrenschmidt <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>
---
hw/display/{vga_template.h => vga-helpers.h} | 0
hw/display/vga.c | 2 +-
2 files changed, 1 insertion(+), 1 deletion(-)
rename hw/display/{vga_template.h => vga-helpers.h} (100%)
diff --git a/hw/display/vga_template.h b/hw/display/vga-helpers.h
similarity index 100%
rename from hw/display/vga_template.h
rename to hw/display/vga-helpers.h
diff --git a/hw/display/vga.c b/hw/display/vga.c
index 21aa2c6..9f60f88 100644
--- a/hw/display/vga.c
+++ b/hw/display/vga.c
@@ -1007,7 +1007,7 @@ void vga_mem_writeb(VGACommonState *s, hwaddr addr,
uint32_t val)
typedef void vga_draw_line_func(VGACommonState *s1, uint8_t *d,
const uint8_t *s, int width);
-#include "vga_template.h"
+#include "vga-helpers.h"
/* return true if the palette was modified */
static int update_palette16(VGACommonState *s)
--
1.8.3.1
- [Qemu-devel] [PULL 00/10] vga: cleanups, prepare for endianness switching, Gerd Hoffmann, 2014/10/02
- [Qemu-devel] [PULL 04/10] vga: Remove rgb_to_pixel indirection, Gerd Hoffmann, 2014/10/02
- [Qemu-devel] [PULL 03/10] vga: Separate LE and BE conversion functions, Gerd Hoffmann, 2014/10/02
- [Qemu-devel] [PULL 05/10] vga: Simplify vga_draw_blank() a bit, Gerd Hoffmann, 2014/10/02
- [Qemu-devel] [PULL 02/10] vga: Remove remainder of old conversion cruft, Gerd Hoffmann, 2014/10/02
- [Qemu-devel] [PULL 10/10] vga: Add endian to vmstate, Gerd Hoffmann, 2014/10/02
- [Qemu-devel] [PULL 06/10] cirrus: Remove non-32bpp cursor drawing, Gerd Hoffmann, 2014/10/02
- [Qemu-devel] [PULL 09/10] vga: Make fb endian a common state variable, Gerd Hoffmann, 2014/10/02
- [Qemu-devel] [PULL 01/10] vga: Start cutting out non-32bpp conversion support, Gerd Hoffmann, 2014/10/02
- [Qemu-devel] [PULL 08/10] vga: Rename vga_template.h to vga-helpers.h,
Gerd Hoffmann <=
- [Qemu-devel] [PULL 07/10] vga: Remove some "should be done in BIOS" comments, Gerd Hoffmann, 2014/10/02
- Re: [Qemu-devel] [PULL 00/10] vga: cleanups, prepare for endianness switching, Peter Maydell, 2014/10/02