[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH v2 00/11] vga: cleanup and endianness patch series
From: |
Gerd Hoffmann |
Subject: |
[Qemu-devel] [PATCH v2 00/11] vga: cleanup and endianness patch series |
Date: |
Mon, 29 Sep 2014 11:31:01 +0200 |
Hi,
Here comes v2 of the vga patches, this time the two patch series
combined into one. Fixed issues found by David Gibson in review,
fixed some codestyle issues. Nothing major. Should be ready for
merge now, /me plans to send a pull req later this week, possibly
excluding patch #11 as I'd like to have ppc64le testing feedback
for that one first.
please review,
Gerd
Benjamin Herrenschmidt (10):
vga: Start cutting out non-32bpp conversion support
vga: Remove remainder of old conversion cruft
vga: Separate LE and BE conversion functions
vga: Remove rgb_to_pixel indirection
vga: Simplify vga_draw_blank() a bit
cirrus: Remove non-32bpp cursor drawing
vga: Remove some "should be done in BIOS" comments
vga: Rename vga_template.h to vga-helpers.h
vga: Make fb endian a common state variable
vga: Add endian control register
Gerd Hoffmann (1):
vga-pci: add qext region to mmio
docs/specs/standard-vga.txt | 9 +
hw/display/cirrus_vga.c | 79 +++---
hw/display/cirrus_vga_template.h | 102 -------
hw/display/{vga_template.h => vga-helpers.h} | 318 +++++++++++-----------
hw/display/vga-pci.c | 68 +++++
hw/display/vga.c | 382 +++++++--------------------
hw/display/vga_int.h | 5 +-
include/hw/i386/pc.h | 8 +
8 files changed, 381 insertions(+), 590 deletions(-)
delete mode 100644 hw/display/cirrus_vga_template.h
rename hw/display/{vga_template.h => vga-helpers.h} (52%)
--
1.8.3.1
- [Qemu-devel] [PATCH v2 00/11] vga: cleanup and endianness patch series,
Gerd Hoffmann <=
- [Qemu-devel] [PATCH v2 07/11] vga: Remove some "should be done in BIOS" comments, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 09/11] vga: Make fb endian a common state variable, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 08/11] vga: Rename vga_template.h to vga-helpers.h, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 06/11] cirrus: Remove non-32bpp cursor drawing, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 04/11] vga: Remove rgb_to_pixel indirection, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 01/11] vga: Start cutting out non-32bpp conversion support, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 11/11] vga-pci: add qext region to mmio, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 02/11] vga: Remove remainder of old conversion cruft, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 03/11] vga: Separate LE and BE conversion functions, Gerd Hoffmann, 2014/09/29