[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH v2 07/11] vga: Remove some "should be done in BIOS"
From: |
Gerd Hoffmann |
Subject: |
[Qemu-devel] [PATCH v2 07/11] vga: Remove some "should be done in BIOS" comments |
Date: |
Mon, 29 Sep 2014 11:31:08 +0200 |
From: Benjamin Herrenschmidt <address@hidden>
Not all platforms have a VGA BIOS, powerpc typically relies on
using the DISPI interface to initialize the card.
Signed-off-by: Benjamin Herrenschmidt <address@hidden>
Signed-off-by: Gerd Hoffmann <address@hidden>
Reviewed-by: David Gibson <address@hidden>
---
hw/display/vga.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/hw/display/vga.c b/hw/display/vga.c
index c3df0c5..21aa2c6 100644
--- a/hw/display/vga.c
+++ b/hw/display/vga.c
@@ -761,14 +761,13 @@ void vbe_ioport_write_data(void *opaque, uint32_t addr,
uint32_t val)
s->vbe_regs[VBE_DISPI_INDEX_ENABLE] |= VBE_DISPI_ENABLED;
vbe_fixup_regs(s);
- /* clear the screen (should be done in BIOS) */
+ /* clear the screen */
if (!(val & VBE_DISPI_NOCLEARMEM)) {
memset(s->vram_ptr, 0,
s->vbe_regs[VBE_DISPI_INDEX_YRES] *
s->vbe_line_offset);
}
- /* we initialize the VGA graphic mode (should be done
- in BIOS) */
+ /* we initialize the VGA graphic mode */
/* graphic mode + memory map 1 */
s->gr[VGA_GFX_MISC] = (s->gr[VGA_GFX_MISC] & ~0x0c) | 0x04 |
VGA_GR06_GRAPHICS_MODE;
@@ -801,7 +800,6 @@ void vbe_ioport_write_data(void *opaque, uint32_t addr,
uint32_t val)
(shift_control << 5);
s->cr[VGA_CRTC_MAX_SCAN] &= ~0x9f; /* no double scan */
} else {
- /* XXX: the bios should do that */
s->bank_offset = 0;
}
s->dac_8bit = (val & VBE_DISPI_8BIT_DAC) > 0;
--
1.8.3.1
- [Qemu-devel] [PATCH v2 00/11] vga: cleanup and endianness patch series, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 07/11] vga: Remove some "should be done in BIOS" comments,
Gerd Hoffmann <=
- [Qemu-devel] [PATCH v2 09/11] vga: Make fb endian a common state variable, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 08/11] vga: Rename vga_template.h to vga-helpers.h, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 06/11] cirrus: Remove non-32bpp cursor drawing, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 04/11] vga: Remove rgb_to_pixel indirection, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 01/11] vga: Start cutting out non-32bpp conversion support, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 11/11] vga-pci: add qext region to mmio, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 02/11] vga: Remove remainder of old conversion cruft, Gerd Hoffmann, 2014/09/29
- [Qemu-devel] [PATCH v2 03/11] vga: Separate LE and BE conversion functions, Gerd Hoffmann, 2014/09/29