qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v1 3/3] monitor: add del completion for peripher


From: Andreas Färber
Subject: Re: [Qemu-devel] [PATCH v1 3/3] monitor: add del completion for peripheral device
Date: Fri, 26 Sep 2014 11:29:41 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.1.0

Hi,

Am 18.09.2014 um 09:53 schrieb Zhu Guihua:
> Add peripheral_device_del_completion() to let peripheral device del completion
> be possible.
> 
> Signed-off-by: Zhu Guihua <address@hidden>
> ---
>  monitor.c | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
> 
> diff --git a/monitor.c b/monitor.c
> index 667efb7..c0e00e4 100644
> --- a/monitor.c
> +++ b/monitor.c
> @@ -4351,6 +4351,29 @@ static void device_del_bus_completion(ReadLineState 
> *rs,  BusState *bus,
>      }
>  }
>  
> +static void peripheral_device_del_completion(ReadLineState *rs,
> +                                             const char *str, size_t len)
> +{
> +    Object *peripheral;
> +    DeviceState *dev = NULL;
> +    ObjectProperty *prop;
> +
> +    peripheral = object_resolve_path("/machine/peripheral/", NULL);
> +
> +    if (peripheral == NULL) {
> +        return;
> +    }
> +
> +    QTAILQ_FOREACH(prop, &peripheral->properties, node) {
> +        if (object_property_is_child(prop)) {
> +            dev = DEVICE(object_property_get_opaque(prop, NULL));

Why so complicated? Can't you use object_child_foreach()?
That would obsolete patches 1-2, leaving the gory details in QOM code
and making this a monitor-only series.

> +            if (dev->id && !strncmp(str, dev->id, len)) {

All devices in /machine/peripheral/ should have an id, but better safe
than sorry. :)

If you do respin, I'd have a preference for strncmp() == 0 for clarity.

> +                readline_add_completion(rs, dev->id);
> +            }
> +        }
> +    }
> +}
> +
>  void chardev_remove_completion(ReadLineState *rs, int nb_args, const char 
> *str)
>  {
>      size_t len;
> @@ -4424,6 +4447,7 @@ void device_del_completion(ReadLineState *rs, int 
> nb_args, const char *str)
>      len = strlen(str);
>      readline_set_completion_index(rs, len);
>      device_del_bus_completion(rs, sysbus_get_default(), str, len);
> +    peripheral_device_del_completion(rs, str, len);
>  }
>  
>  void object_del_completion(ReadLineState *rs, int nb_args, const char *str)

Whether these two are correct, would then just need to be reviewed by
someone who knows about completion (not me).

Regards,
Andreas

-- 
SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany
GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer; HRB 16746 AG Nürnberg



reply via email to

[Prev in Thread] Current Thread [Next in Thread]