[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] aarch64 & gdb: warning: while parsing target descriptio

From: Christopher Covington
Subject: Re: [Qemu-devel] aarch64 & gdb: warning: while parsing target description (at line 1): Could not load XML document "arm-core.xml"
Date: Thu, 07 Aug 2014 09:43:33 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130106 Thunderbird/17.0.2

On 08/07/2014 08:03 AM, Peter Maydell wrote:
> On 7 August 2014 12:43, Richard W.M. Jones <address@hidden> wrote:
>> On Thu, Aug 07, 2014 at 12:35:27PM +0100, Peter Maydell wrote:
>>> On 7 August 2014 12:29, Richard W.M. Jones <address@hidden> wrote:
>>>> On Thu, Aug 07, 2014 at 12:18:49PM +0100, Peter Maydell wrote:
>>>>> you didn't select a 32 bit CPU either explicitly or by default
>>>>> on the QEMU command line? Note that '-machine type=virt'
>>>>> defaults to a Cortex-A15 even in qemu-softmmu-aarch64
>>>>> (this is unfortunate but fallout from the fact that we started
>>>>> the virt model with the A15. Maybe we should make it not
>>>>> have a default and require a CPU specification...)
>>>> Yes, this is indeed the case.  It also explains why I could get TCG
>>>> working at all until I added -cpu cortex-a57.  Now it is working.
>>>> I really think this choice of cpu_model = "cortex-a15" for -M virt is
>>>> a poor one.  It should always default to something working.
>>> cortex-a15 *does* work, it's just a 32 bit CPU. It will function
>>> exactly the same as if you asked for an A15 in qemu-system-arm.
>>> Obviously if you try to feed it an AArch64 kernel it will behave
>>> the same way as if you'd tried to boot an AArch64 kernel on
>>> A15 hardware, so don't do that.
>> Can't a 32 bit kernel run on -cpu cortex-a5x?  (I've not tried.)
> No, because at the moment our AArch64 TCG implementation
> (and the way we configure KVM) assumes that the highest
> exception level is running AArch64. We might fix this eventually,
> though.

When EL3 and EL2 support is added, the bootloader will presumably have to be
modified to make the switch from EL3 into EL2. In my experience switching into
AArch32 EL2 instead of AArch64 EL2 is an easy option to add.


Employee of Qualcomm Innovation Center, Inc.
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
hosted by the Linux Foundation.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]