[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH v2 0/9] tcg: tidy the type of code_ptr
From: |
Richard Henderson |
Subject: |
[Qemu-devel] [PATCH v2 0/9] tcg: tidy the type of code_ptr |
Date: |
Tue, 1 Apr 2014 13:53:25 -0700 |
Here's a second revision, attempting to take Peter's review on board.
In particular, inlines to hide some of the pointer differencing issues.
I also chose a different name for the type: tcg_insn_unit as suggested
by Jay Foad.
r~
Peter Maydell (3):
exec-all.h: Use stl_p to avoid undefined behaviour patching x86 jumps
tcg: Avoid stores to unaligned addresses
tcg: Avoid undefined behaviour patching code at unaligned addresses
Richard Henderson (6):
tcg: Introduce byte pointer arithmetic helpers
tcg: Define tcg_insn_unit for code pointers
tcg-i386: Define TCG_TARGET_INSN_UNIT_SIZE
tcg-ppc64: Define TCG_TARGET_INSN_UNIT_SIZE
tcg-ppc: Define TCG_TARGET_INSN_UNIT_SIZE
tcg-sparc: Define TCG_TARGET_INSN_UNIT_SIZE
include/exec/exec-all.h | 4 +-
tcg/i386/tcg-target.c | 60 +++++++--------
tcg/i386/tcg-target.h | 1 +
tcg/ppc/tcg-target.c | 194 +++++++++++++++++++++++-------------------------
tcg/ppc/tcg-target.h | 1 +
tcg/ppc64/tcg-target.c | 163 ++++++++++++++++++++--------------------
tcg/ppc64/tcg-target.h | 1 +
tcg/sparc/tcg-target.c | 138 ++++++++++++++++------------------
tcg/sparc/tcg-target.h | 2 +-
tcg/tcg-be-ldst.h | 4 +-
tcg/tcg.c | 108 +++++++++++++++++++--------
tcg/tcg.h | 84 ++++++++++++++++++---
translate-all.c | 13 ++--
13 files changed, 432 insertions(+), 341 deletions(-)
--
1.9.0
- [Qemu-devel] [PATCH v2 0/9] tcg: tidy the type of code_ptr,
Richard Henderson <=
- [Qemu-devel] [PATCH v2 1/9] exec-all.h: Use stl_p to avoid undefined behaviour patching x86 jumps, Richard Henderson, 2014/04/01
- [Qemu-devel] [PATCH v2 2/9] tcg: Avoid stores to unaligned addresses, Richard Henderson, 2014/04/01
- [Qemu-devel] [PATCH v2 3/9] tcg: Avoid undefined behaviour patching code at unaligned addresses, Richard Henderson, 2014/04/01
- [Qemu-devel] [PATCH v2 4/9] tcg: Introduce byte pointer arithmetic helpers, Richard Henderson, 2014/04/01
- [Qemu-devel] [PATCH v2 5/9] tcg: Define tcg_insn_unit for code pointers, Richard Henderson, 2014/04/01
- [Qemu-devel] [PATCH v2 6/9] tcg-i386: Define TCG_TARGET_INSN_UNIT_SIZE, Richard Henderson, 2014/04/01
- [Qemu-devel] [PATCH v2 7/9] tcg-ppc64: Define TCG_TARGET_INSN_UNIT_SIZE, Richard Henderson, 2014/04/01
- [Qemu-devel] [PATCH v2 8/9] tcg-ppc: Define TCG_TARGET_INSN_UNIT_SIZE, Richard Henderson, 2014/04/01