[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 1221966] Re: SIGSEGV in static_code_gen_buffer

From: William D Colburn
Subject: [Qemu-devel] [Bug 1221966] Re: SIGSEGV in static_code_gen_buffer
Date: Tue, 10 Sep 2013 14:40:31 -0000

Oh is it?  Sorry, I guess I didn't understand what that function was
doing.  That thing is sort of confusing in there...

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  SIGSEGV in static_code_gen_buffer

Status in QEMU:

Bug description:
  Trying to run 'ls' (or, anything else as far as I can tell) from a
  SunOS 5.8 box under RHEL 6.4 linux, I get a segfault.  I've tried
  qemu-1.5.3, qemu-1.6.0, and I fetched git://git.qemu-
  project.org/qemu.git.  I've also tried a statically linked sh from
  /sbin/ and it also segfaulted.

  address@hidden</home/anotheruvula/qemu>$ gdb bin/qemu-sparc
  GNU gdb (GDB) Red Hat Enterprise Linux (7.2-60.el6_4.1)
  Copyright (C) 2010 Free Software Foundation, Inc.
  License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
  This is free software: you are free to change and redistribute it.
  There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
  and "show warranty" for details.
  This GDB was configured as "x86_64-redhat-linux-gnu".
  For bug reporting instructions, please see:
  Reading symbols from /home/anotheruvula/qemu/bin/qemu-sparc...done.
  (gdb) run ../sparc/ls
  Starting program: /home/anotheruvula/qemu/bin/qemu-sparc ../sparc/ls
  [Thread debugging using libthread_db enabled]

  Program received signal SIGSEGV, Segmentation fault.
  0x00007ffff8259116 in static_code_gen_buffer ()
  Missing separate debuginfos, use: debuginfo-install glib2-2.22.5-7.el6.x86_64 
  (gdb) where
  #0  0x00007ffff8259116 in static_code_gen_buffer ()
  #1  0x00007ffff7f570cd in cpu_tb_exec (cpu=0x7ffffa2b1210, tb_ptr=
      0x7ffff82590d0 "A\213n \205í\017\205Í")
      at /home/anotheruvula/qemu-devel/cpu-exec.c:56
  #2  0x00007ffff7f57b2d in cpu_sparc_exec (env=0x7ffffa2b1348)
      at /home/anotheruvula/qemu-devel/cpu-exec.c:631
  #3  0x00007ffff7f77f36 in cpu_loop (env=0x7ffffa2b1348)
      at /home/anotheruvula/qemu-devel/linux-user/main.c:1089
  #4  0x00007ffff7f798ff in main (argc=2, argv=0x7fffffffdfc8, envp=
      0x7fffffffdfe0) at /home/anotheruvula/qemu-devel/linux-user/main.c:4083

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]