[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH] Switch the roles of jmp_next[0] and jmp_next[1]

From: Zhihui Zhang
Subject: Re: [Qemu-devel] [PATCH] Switch the roles of jmp_next[0] and jmp_next[1].
Date: Sun, 23 Jun 2013 22:52:12 -0400

My intention was to make things consistent for readability.  In the case of gen_jz_ecx_string(), jmp_next[1] is already the "not taken" case.  However, looks like the meaning of jmp_next changes in the case of a TB loop, it does not point to the next TB to execute any more. Anyway, I thought this patch can reduce some confusion.

On Sun, Jun 23, 2013 at 2:22 PM, Richard Henderson <address@hidden> wrote:
On 06/22/2013 09:10 AM, Zhihui Zhang wrote:
> This way, jmp_next[0] means "taken" for both conditional jumps AND unconditional jumps.
> Currently, it has opposite meanings for the two cases.

So?  There's no proscribed meaning for the 0 and 1 indices.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]