qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 13/20] target-i386: set custom 'vendor' without


From: Eduardo Habkost
Subject: Re: [Qemu-devel] [PATCH 13/20] target-i386: set custom 'vendor' without intermediate x86_def_t
Date: Thu, 27 Dec 2012 17:22:45 -0200
User-agent: Mutt/1.5.21 (2010-09-15)

On Thu, Dec 27, 2012 at 03:59:29PM +0100, Igor Mammedov wrote:
> Signed-off-by: Igor Mammedov <address@hidden>

Reviewed-by: Eduardo Habkost <address@hidden>

I would write it as
  qdict_put(*props, "vendor", qstring_from_str(val))
instead. It would make the property-setting code more greppable (and
easier to read IMO).

On the other hand, using featurestr as the key makes sense if the
trivial qdict_put() calls like this one are eventually going to be
unified into a single qdict_put(*props, featurestr, qstring_from_str(val))
generic fallback.

> ---
>  target-i386/cpu.c |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/target-i386/cpu.c b/target-i386/cpu.c
> index 3ead1f4..084faeb 100644
> --- a/target-i386/cpu.c
> +++ b/target-i386/cpu.c
> @@ -1338,7 +1338,7 @@ static int cpu_x86_parse_featurestr(x86_def_t 
> *x86_cpu_def, char *features,
>                  }
>                  x86_cpu_def->xlevel = numvalue;
>              } else if (!strcmp(featurestr, "vendor")) {
> -                pstrcpy(x86_cpu_def->vendor, sizeof(x86_cpu_def->vendor), 
> val);
> +                qdict_put(*props, featurestr, qstring_from_str(val));
>              } else if (!strcmp(featurestr, "model_id")) {
>                  pstrcpy(x86_cpu_def->model_id, sizeof(x86_cpu_def->model_id),
>                          val);
> -- 
> 1.7.1
> 

-- 
Eduardo



reply via email to

[Prev in Thread] Current Thread [Next in Thread]