qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH 0/4] virtio-serial: Rework, fix post_load code


From: Amit Shah
Subject: [Qemu-devel] [PATCH 0/4] virtio-serial: Rework, fix post_load code
Date: Thu, 13 Dec 2012 16:07:52 +0530

This series reworks the post_load code recently introduced to allocate
the structures only when required (i.e. only at load time).  This
helps keep the VirtIOSerial struct clean, and use less RAM.

Also rearrange the code in virtio_serial_load() for easier
readability.

Patch 4 fixes a race with the timer going off after a device got
hot-unplugged, and patch 1 uses unsigned int (uint32_t) type to count
ports, as in the rest of the code.

Please review.

Amit Shah (4):
  virtio-serial: use uint32_t to count ports
  virtio-serial: move active ports loading to separate function
  virtio-serial: allocate post_load only at load-time
  virtio-serial: delete timer if active during exit

 hw/virtio-serial-bus.c | 150 +++++++++++++++++++++++++++++--------------------
 1 file changed, 89 insertions(+), 61 deletions(-)

-- 
1.8.0.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]