qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 6/9] omap_lcdc: omap_ppm_save(): add error handl


From: Luiz Capitulino
Subject: Re: [Qemu-devel] [PATCH 6/9] omap_lcdc: omap_ppm_save(): add error handling
Date: Thu, 30 Aug 2012 08:38:37 -0300

On Wed, 29 Aug 2012 22:28:38 +0100
Peter Maydell <address@hidden> wrote:

> On 29 August 2012 20:53, Luiz Capitulino <address@hidden> wrote:
> > Signed-off-by: Luiz Capitulino <address@hidden>
> > ---
> >  hw/omap_lcdc.c | 59 
> > ++++++++++++++++++++++++++++++++++++++++++++--------------
> >  1 file changed, 45 insertions(+), 14 deletions(-)
> >
> > diff --git a/hw/omap_lcdc.c b/hw/omap_lcdc.c
> > index 3d6328f..e2ba108 100644
> > --- a/hw/omap_lcdc.c
> > +++ b/hw/omap_lcdc.c
> > @@ -224,18 +224,24 @@ static void omap_update_display(void *opaque)
> >      omap_lcd->invalidate = 0;
> >  }
> >
> > -static int omap_ppm_save(const char *filename, uint8_t *data,
> > -                    int w, int h, int linesize)
> > +static void omap_ppm_save(const char *filename, uint8_t *data,
> > +                    int w, int h, int linesize, Error **errp)
> >  {
> >      FILE *f;
> >      uint8_t *d, *d1;
> >      unsigned int v;
> > -    int y, x, bpp;
> > +    int ret, y, x, bpp;
> >
> >      f = fopen(filename, "wb");
> > -    if (!f)
> > -        return -1;
> > -    fprintf(f, "P6\n%d %d\n%d\n", w, h, 255);
> > +    if (!f) {
> > +        error_setg(errp, "failed to open file '%s': %s", filename,
> > +                   strerror(errno));
> > +        return;
> > +    }
> > +    ret = fprintf(f, "P6\n%d %d\n%d\n", w, h, 255);
> > +    if (ret < 0) {
> > +        goto write_err;
> > +    }
> 
> We don't use 'ret' in write_err, so why not just
>       if (fprintf(f....)  < 0) {
>           goto write_err;
>       }
> 
> here and similarly below and drop the variable altogether?

For clarity. This is probably a matter of taste, but I much more prefer
separate statements (vs. saving 4 bytes during the function call).



reply via email to

[Prev in Thread] Current Thread [Next in Thread]