qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 2/6] kvm: Rename kvm_irqchip_set_irq to kvm_inje


From: Avi Kivity
Subject: Re: [Qemu-devel] [PATCH 2/6] kvm: Rename kvm_irqchip_set_irq to kvm_inject_async_irq
Date: Wed, 25 Jul 2012 18:47:37 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120615 Thunderbird/13.0.1

On 07/25/2012 04:24 PM, Peter Maydell wrote:
> Rename the function kvm_irqchip_set_irq() to kvm_inject_async_irq(),
> since it can be used for asynchronous interrupt injection whether
> there is a full irqchip model in the kernel or not.
> 

> @@ -144,7 +144,7 @@ int kvm_arch_on_sigbus(int code, void *addr);
>  
>  void kvm_arch_init_irq_routing(KVMState *s);
>  
> -int kvm_irqchip_set_irq(KVMState *s, int irq, int level);
> +int kvm_inject_async_irq(KVMState *s, int irq, int level);
>  int kvm_irqchip_send_msi(KVMState *s, MSIMessage msg);
>  

"interrupt injection" refers to the act of setting up an interrupt to be
delivered to the guest at the next entry, so it is synchronous by
nature.  It was sloppy of me to use the term, but let's not introduce it
to the code as well.

The correct terminology would be:
  interrupt injection: synchronous, in-vcpu, after all masks have been
evaluated.  Straight into the vein.
  interrupt queueing: asynchronous, extra-vcpu, before any masks

Since interrupt queueing (well that name isn't perfect for level
triggered interrupts, since it may not queue anything...) is the norm, I
think it's better to keep the set_irq() naming and mark the synchronous
interrupt injection function as special.

-- 
error compiling committee.c: too many arguments to function





reply via email to

[Prev in Thread] Current Thread [Next in Thread]