[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] an error while loading checkpoint

From: sparsh mittal
Subject: Re: [Qemu-devel] an error while loading checkpoint
Date: Thu, 8 Dec 2011 08:50:09 -0600

I also have question whether -icount 0 or -icount auto can make a simulation more deterministic and whether qemu is affected by the load on the host (i.e. how many processes are running?) I would be grateful for a reply.
Thanks and Regards
Sparsh Mittal

On Thu, Dec 8, 2011 at 8:36 AM, sparsh mittal <address@hidden> wrote:

On Thu, Dec 8, 2011 at 8:18 AM, Stefan Hajnoczi <address@hidden> wrote:
On Thu, Dec 8, 2011 at 1:57 PM, sparsh mittal <address@hidden> wrote:
> I am using qemu as a part of Marss cycle-accurate simulator.
> http://marss86.org/~marss86/index.php/Home
> $ qemu/qemu-system-x86_64 -m 4G -snapshot -loadvm ffnn -vnc :3 -icount 0
> -drive cache=unsafe,file=/local/sparsh/specimage_sftn3.qcow2 -simconfig
> MyConfigs/ffnn_100M.cfg

I wonder if the image loads in vanilla QEMU.  Try dropping the -icount
0 and -simconfig options just to see whether vanilla QEMU gets the
same error or not.

I have tried dropping all these: snapshot, icount, vnc, cache=unsafe, but still the error comes. I deleted this checkpoint and made another one (with different name, but same benchmarks), still error comes.
I will also ask marss-forum.
Surprisingly, with other checkpoints, error does not come.
Also, have you asked on the Marss mailing list?  Please try that first
because the bug may be due to changes that were made to vanilla QEMU.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]