[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 16/19] Rename get_tls to tls_var

From: Jan Kiszka
Subject: Re: [Qemu-devel] [PATCH 16/19] Rename get_tls to tls_var
Date: Tue, 06 Dec 2011 12:47:36 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv: Gecko/20080226 SUSE/ Thunderbird/ Mnenhy/

On 2011-12-06 12:43, Andreas Färber wrote:
> Am 06.12.2011 12:01, schrieb Stefan Hajnoczi:
>> From: Jan Kiszka <address@hidden>
>> get_tls() can serve as a lvalue as well, so 'get' might be confusing.
> Note that this does not work for POSIX pthread_getspecific(), which
> we'll need to support at some point in time, so I don't think this is a
> terribly good idea.
> At least please don't start actually using it as lvalue, we'd need a
> set_tls() for assignment (in which case get_tls() would've provided nice
> symmetry).

We already use it like this as TLS is not usable otherwise.

I don't mind get/set_tls, I just didn't like current get_tls(x) = bla.


Siemens AG, Corporate Technology, CT T DE IT 1
Corporate Competence Center Embedded Linux

reply via email to

[Prev in Thread] Current Thread [Next in Thread]