[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Boot from disk problem

From: Ignacio Geli
Subject: Re: [Qemu-devel] Boot from disk problem
Date: Mon, 05 Dec 2011 11:53:20 -0300
User-agent: Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20111124 Thunderbird/8.0

El 02/12/11 18:47, Artyom Tarasenko escribió:
On Fri, Dec 2, 2011 at 1:48 PM, Ignacio Geli <address@hidden> wrote:
El 01/12/11 07:29, Artyom Tarasenko escribió:

On Sat, Nov 26, 2011 at 9:01 AM, Blue Swirl <address@hidden> wrote:

On Fri, Nov 25, 2011 at 18:24, Ignacio Geli <address@hidden> wrote:

El 25/11/11 13:01, Andreas Färber escribió:


Am 25.11.2011 16:23, schrieb Ignacio Geli:

Im trying to run a solaris 2.5.1 vm acording the instructions of i found
in this blog:

I'm not sure if Artyom has submitted all his patches to QEMU yet.

This stuff is in. Definitely worked at 0.13 - 0.14 times, but I never
had time to check 0.15+.

compile my qemu with:
git clone git://git.savannah.nongnu.org/qemu.git
cd qemu
./configure --target-list=sparc-softmmu
(version 0.13.50)

That 2009 blog is outdated: QEMU now lives in
and should be at 0.15.93 (1.0-rc3). Compare http://qemu.org for details.

CC'ed sparc maintainer and Artyom.


Andesas tks for the info.
upgrading to 0.15.1 did not solve the issue.

Adding some info:

QEMU emulator version 0.15.1, Copyright (c) 2003-2008 Fabrice Bellard
Linux ws2132 2.6.32-5-openvz-amd64 #1 SMP Mon Oct 3 05:12:50 UTC 2011 x86_64 GNU/Linux
Debian squeeze


Ive downloaded the ss5.bin bios (sparc station 5)) I have the solaris
disk and i can do the installation but can't get the disk to boot.

I can boot from the cd, mount and check the /etc/system file it has the
"set scsi_options=0x58" option i set to make it work, still not working:

Here is the output:

/ok boot disk0:d
Boot device: /iommu/sbus/address@hidden,8400000/address@hidden,8800000/address@hidden,0:d  File
and args:
SunOS Release 5.5.1 Version Generic [UNIX(R) System V Release 4.0]
Copyright (c) 1983-1996, Sun Microsystems, Inc.
    corrupt label - bad geometry

    Label says 1310720 blocks, Drive says 883120 blocks
Cannot mount root on
/address@hidden,10000000/address@hidden,10001000/address@hidden,8400000/address@hidden,8800000/address@hidden,0:d fstype
panic: vfs_mountroot: cannot mount root
Resetting ... /

maybe the disk is wrong
ive try several disk one following these instructions:
1) qemu-img create -f qcow2 file.qcow2 12G
2) Add -drive file=file.qcow2,unit=3 to your qemu startup
3) Boot single user
4) echo


I'd guess these geometry parameters are not correct for your 12G disk.
It's strange though that the installer kernel sees different geometry
from the normal boot kernel.

5) echo


These could also be wrong, but I have no idea what the numbers mean.

In order not to mess with all this numbers I used a pre-defined 1.3G
disk in the Solaris format utility and created it with dd:
dd if=/dev/zero of=$1  bs=10k count=133756

Otherwise, Ignacio, are you sure that disk0 is your root FS disk and
not something else? Can you post your qemu command line?

qemu-system-sparc -M SS-5 -startdate "2009-12-13" -bios /root/ss5.bin -nographic -hda /root/imagenes/solaris.disk -hdb /root/solaris_2.5.1_1197.iso

Looking at your command, I don't think it complains about
solaris.disk. I think it complains about the iso, which is normal
given that we make iso image pretend it's a hard drive.

But why do you boot from the slice d of disk0 ? Please try

boot disk0 -v

and post here a complete log afterwards.
Arytom tks I really sorry don't know why i was doing it from the slice d.
I boot from the solaris disk, format and label the disk and install again.
it works now but the problem was the slice d

Thkst  all and I apologize again

Thks for your help Artyom. I'll try with a dd, and solaris format utility and I'll let u know



        Simplicity is the ultimate sophistication

        Ignacio Geli
        Implementación y Soporte

Artyom Tarasenko

solaris/sparc under qemu blog: http://tyom.blogspot.com/


        Simplicity is the ultimate sophistication

        Ignacio Geli
        Implementación y Soporte


reply via email to

[Prev in Thread] Current Thread [Next in Thread]