qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 1/2] arm-linux-user: fix elfload.c's AT_HWCAP to


From: Peter Maydell
Subject: Re: [Qemu-devel] [PATCH 1/2] arm-linux-user: fix elfload.c's AT_HWCAP to reflect cpu features.
Date: Wed, 9 Nov 2011 15:48:17 +0000

On 9 November 2011 15:34, Andreas Färber <address@hidden> wrote:
> Am 09.11.2011 16:02, schrieb Benoît Canet:
>> +#define SET_HWCAP(feat, hwcap) \
>> +    do {if (arm_feature(e, feat)) { hwcaps |= hwcap; } } while (0)
>
> Small nit: I notice there's a space missing after do {.
> I wonder if Coding Style applies to macros, too. In that case this
> should be five lines.

Personally I wouldn't make it five lines...

>> +    SET_HWCAP(ARM_FEATURE_VFP, ARM_HWCAP_ARM_VFP);
>> +    SET_HWCAP(ARM_FEATURE_IWMMXT, ARM_HWCAP_ARM_IWMMXT);
>> +    SET_HWCAP(ARM_FEATURE_THUMB2EE, ARM_HWCAP_ARM_THUMBEE);
>> +    SET_HWCAP(ARM_FEATURE_NEON, ARM_HWCAP_ARM_NEON);
>> +    SET_HWCAP(ARM_FEATURE_VFP3, ARM_HWCAP_ARM_VFPv3);
>> +
>> +    /* Strictly should be ARM_FEATURE_V5TE but we don't distinguish
>> +     * as all our v5 cores are v5TE at the moment
>> +     */
>> +    SET_HWCAP(ARM_FEATURE_V5, ARM_HWCAP_ARM_EDSP);
>
> Peter, usually I'd rather have these things fixed for real before they
> get forgotten, but I take it this one's for 1.0 and a V5TE feature and
> V5TE => V5 inference rule would better be saved for 1.1? (I had a series
> adding inference for V7 => V6 etc. removing duplicated code, not sure if
> I submitted that yet...?)

I wasn't planning to put this in for 1.0. (The only patch I have
that I do want to put in 1.0 is the omap_gpio one.)

I don't think I've seen a patch from you adding the v7->v6->...
inferences. I think it would be a good idea, though, ditto adding
V5TE (if you do then the ENABLE_ARCH_5TE macro in translate.c should
be updated).

-- PMM



reply via email to

[Prev in Thread] Current Thread [Next in Thread]