[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 4/4] qemu-timer: Fix timers for w32

From: Stefan Weil
Subject: Re: [Qemu-devel] [PATCH 4/4] qemu-timer: Fix timers for w32
Date: Mon, 11 Apr 2011 19:21:00 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20110223 Thunderbird/3.1.8

Am 11.04.2011 09:36, schrieb Paolo Bonzini:
On 04/10/2011 08:28 PM, Stefan Weil wrote:
Commit 68c23e5520e8286d79d96ab47c0ea722ceb75041 removed the
multimedia timer, but this timer is needed for certain
Linux kernels. Otherwise Linux boot stops with this error:

     MP-BIOS bug: 8254 timer not connected to IO-APIC

So the multimedia timer is added again here.

Which distribution and Windows version is that? Also, have they tried the non-dynticks timer (win32)?


The bug was reported for a tinycore 3.5.1 guest (linux kernel 3.6.33-3).
The iso image is available from http://distro.ibiblio.org/tinycorelinux/3.x/release/.
QEMU was running on XP SP3.

Other Linux live CD-ROMs (e.g. FC14) were reported to show the same bug
when run as guest.

APIC can be disabled (kernel parameter), without APIC there is no problem.

I see the same bug here with two XP hosts and also tried both timer variants
of current QEMU (without a difference).

I don't get the bug when running on a Linux host using wine.

Regards, Stefan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]