[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] Re: [PATCH 08/20] pci: s/pci_find_host_bus/pci_find_root_bu
From: |
Michael S. Tsirkin |
Subject: |
[Qemu-devel] Re: [PATCH 08/20] pci: s/pci_find_host_bus/pci_find_root_bus/g |
Date: |
Thu, 12 Nov 2009 12:45:31 +0200 |
User-agent: |
Mutt/1.5.19 (2009-01-05) |
On Thu, Nov 12, 2009 at 02:58:36PM +0900, Isaku Yamahata wrote:
> This patch renames pci_find_host_bus() to pci_find_root_bus()
> as suggested by "Michael S. Tsirkin" <address@hidden>.
>
> Signed-off-by: Isaku Yamahata <address@hidden>
Acked-by: Michael S. Tsirkin <address@hidden>
> ---
> hw/pci-hotplug.c | 4 ++--
> hw/pci.c | 8 ++++----
> hw/pci.h | 2 +-
> 3 files changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/hw/pci-hotplug.c b/hw/pci-hotplug.c
> index a254498..081d6d1 100644
> --- a/hw/pci-hotplug.c
> +++ b/hw/pci-hotplug.c
> @@ -113,7 +113,7 @@ void drive_hot_add(Monitor *mon, const QDict *qdict)
> if (pci_read_devaddr(mon, pci_addr, &dom, &pci_bus, &slot)) {
> goto err;
> }
> - dev = pci_find_device(pci_find_host_bus(0), pci_bus, slot, 0);
> + dev = pci_find_device(pci_find_root_bus(0), pci_bus, slot, 0);
> if (!dev) {
> monitor_printf(mon, "no pci device with address %s\n", pci_addr);
> goto err;
> @@ -257,7 +257,7 @@ void pci_device_hot_remove(Monitor *mon, const char
> *pci_addr)
> return;
> }
>
> - d = pci_find_device(pci_find_host_bus(0), bus, slot, 0);
> + d = pci_find_device(pci_find_root_bus(0), bus, slot, 0);
> if (!d) {
> monitor_printf(mon, "slot %d empty\n", slot);
> return;
> diff --git a/hw/pci.c b/hw/pci.c
> index bdd4063..e73f07c 100644
> --- a/hw/pci.c
> +++ b/hw/pci.c
> @@ -146,7 +146,7 @@ static void pci_host_bus_register(int domain, PCIBus *bus)
> QLIST_INSERT_HEAD(&host_buses, host, next);
> }
>
> -PCIBus *pci_find_host_bus(int domain)
> +PCIBus *pci_find_root_bus(int domain)
> {
> struct PCIHostBus *host;
>
> @@ -372,7 +372,7 @@ static int pci_parse_devaddr(const char *addr, int *domp,
> int *busp, unsigned *s
> return -1;
>
> /* Note: QEMU doesn't implement domains other than 0 */
> - if (!pci_find_bus(pci_find_host_bus(dom), bus))
> + if (!pci_find_bus(pci_find_root_bus(dom), bus))
> return -1;
>
> *domp = dom;
> @@ -402,7 +402,7 @@ PCIBus *pci_get_bus_devfn(int *devfnp, const char
> *devaddr)
>
> if (!devaddr) {
> *devfnp = -1;
> - return pci_find_bus(pci_find_host_bus(0), 0);
> + return pci_find_bus(pci_find_root_bus(0), 0);
> }
>
> if (pci_parse_devaddr(devaddr, &dom, &bus, &slot) < 0) {
> @@ -410,7 +410,7 @@ PCIBus *pci_get_bus_devfn(int *devfnp, const char
> *devaddr)
> }
>
> *devfnp = slot << 3;
> - return pci_find_bus(pci_find_host_bus(0), bus);
> + return pci_find_bus(pci_find_root_bus(0), bus);
> }
>
> static void pci_init_cmask(PCIDevice *dev)
> diff --git a/hw/pci.h b/hw/pci.h
> index d3378d3..cd04189 100644
> --- a/hw/pci.h
> +++ b/hw/pci.h
> @@ -295,7 +295,7 @@ PCIDevice *pci_nic_init_nofail(NICInfo *nd, const char
> *default_model,
> const char *default_devaddr);
> int pci_bus_num(PCIBus *s);
> void pci_for_each_device(PCIBus *bus, int bus_num, void (*fn)(PCIBus *bus,
> PCIDevice *d));
> -PCIBus *pci_find_host_bus(int domain);
> +PCIBus *pci_find_root_bus(int domain);
> PCIBus *pci_find_bus(PCIBus *bus, int bus_num);
> PCIDevice *pci_find_device(PCIBus *bus, int bus_num, int slot, int function);
> PCIBus *pci_get_bus_devfn(int *devfnp, const char *devaddr);
> --
> 1.6.0.2
- [Qemu-devel] [PATCH 01/20] pci: fix pci_info_device()., (continued)
- [Qemu-devel] [PATCH 01/20] pci: fix pci_info_device()., Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH 15/20] pci: clean up of pci_update_mappings(), Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH 02/20] pci: move pci_data_{read, write}() declaration from pci.h to pci_host.h, Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH 12/20] pci: remove some unnecessary comment in pci.h, Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH 08/20] pci: s/pci_find_host_bus/pci_find_root_bus/g, Isaku Yamahata, 2009/11/12
- [Qemu-devel] Re: [PATCH 08/20] pci: s/pci_find_host_bus/pci_find_root_bus/g,
Michael S. Tsirkin <=
- [Qemu-devel] [PATCH 03/20] pci: simplify pci_data_read(), pcie_mmcfg_data_read()., Isaku Yamahata, 2009/11/12
[Qemu-devel] [PATCH 05/20] pci: rename pci_addr_to_dev(), pcie_mmcfg_addr_to_dev()., Isaku Yamahata, 2009/11/12
[Qemu-devel] [PATCH 11/20] pci: clean up of pci_init_wmask()., Isaku Yamahata, 2009/11/12
[Qemu-devel] [PATCH 07/20] pci: remove pci_sub_bus() by open coding., Isaku Yamahata, 2009/11/12