[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH 17/20] pci: remove magic number, 256 in pci.c
From: |
Isaku Yamahata |
Subject: |
[Qemu-devel] [PATCH 17/20] pci: remove magic number, 256 in pci.c |
Date: |
Thu, 12 Nov 2009 14:58:45 +0900 |
This patch replaces magic number, 256, with ARRAY_SIZE().
Signed-off-by: Isaku Yamahata <address@hidden>
---
hw/pci.c | 5 +++--
1 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/hw/pci.c b/hw/pci.c
index 2eff7fe..dce445a 100644
--- a/hw/pci.c
+++ b/hw/pci.c
@@ -487,7 +487,8 @@ static PCIDevice *do_pci_register_device(PCIDevice
*pci_dev, PCIBus *bus,
uint8_t header_type)
{
if (devfn < 0) {
- for(devfn = bus->devfn_min ; devfn < 256; devfn += 8) {
+ for(devfn = bus->devfn_min ; devfn < ARRAY_SIZE(bus->devices);
+ devfn += 8) {
if (!bus->devices[devfn])
goto found;
}
@@ -1025,7 +1026,7 @@ static void pci_for_each_device_under_bus(PCIBus *bus,
PCIDevice *d;
int devfn;
- for(devfn = 0; devfn < 256; devfn++) {
+ for(devfn = 0; devfn < ARRAY_SIZE(bus->devices); devfn++) {
d = bus->devices[devfn];
if (d)
fn(bus, d);
--
1.6.0.2
- [Qemu-devel] Re: [PATCH 16/20] pci: kill goto in pci_update_mappings(), (continued)
- [Qemu-devel] [PATCH 14/20] pci: remove unused constants., Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH 19/20] pci: pci bridge related clean up., Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH 13/20] pci: move typedef, PCIHostState, PCIExpressHost to qemu-common.h., Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH 20/20] pci: remove goto in pci_bridge_filter()., Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH 17/20] pci: remove magic number, 256 in pci.c,
Isaku Yamahata <=
- [Qemu-devel] [PATCH 10/20] pci: kill unnecessary included in pci.c, Isaku Yamahata, 2009/11/12
- [Qemu-devel] [PATCH 04/20] pci: remove pci_addr_to_config() by open code, Isaku Yamahata, 2009/11/12
- [Qemu-devel] Re: [PATCH 00/20] PCI express clean up patches., Michael S. Tsirkin, 2009/11/12