qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Re: [PATCH 06/14] Rename SLIRP_OBJS to slirp-obj-y


From: Juan Quintela
Subject: [Qemu-devel] Re: [PATCH 06/14] Rename SLIRP_OBJS to slirp-obj-y
Date: Thu, 25 Jun 2009 09:50:44 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.3 (gnu/linux)

Mark McLoughlin <address@hidden> wrote:
> On Thu, 2009-06-25 at 00:08 +0200, address@hidden wrote:
>
>> diff --git a/Makefile b/Makefile
>> index 802d276..d316388 100644
>> --- a/Makefile
>> +++ b/Makefile
>> @@ -188,10 +188,10 @@ endif
>> 
>>  ifdef CONFIG_SLIRP
>>  CPPFLAGS+=-I$(SRC_PATH)/slirp
>> -SLIRP_OBJS=cksum.o if.o ip_icmp.o ip_input.o ip_output.o \
>> -slirp.o mbuf.o misc.o sbuf.o socket.o tcp_input.o tcp_output.o \
>> -tcp_subr.o tcp_timer.o udp.o bootp.o debug.o tftp.o
>> -OBJS+=$(addprefix slirp/, $(SLIRP_OBJS))
>> +slirp-obj-y = cksum.o if.o ip_icmp.o ip_input.o ip_output.o
>> +slirp-obj-y += slirp.o mbuf.o misc.o sbuf.o socket.o tcp_input.o 
>> tcp_output.o
>> +slirp-obj-y += tcp_subr.o tcp_timer.o udp.o bootp.o debug.o tftp.o
>> +OBJS+=$(addprefix slirp/, $(slirp-obj-y))
>
> I like the whole series, but I think I'd drop this change and the
> XEN_OBJS change.
>
> We won't be individually configuring out any of SLIRP_OBJS, so an end
> result like:
>
>   obj-$(CONFIG_SLIRP) += $(addprefix slirp/, $(SLIRP_OBJS))
>
> seems nicer to me than:
>
>   obj-$(CONFIG_SLIRP) += $(addprefix slirp/, $(slirp-obj-y))

I haven't looked at SLIRP, just wondered if we wanted to remove
bootp/tftp at any moment.  I tried to Make all the Makefiles use the
same style.

> Cheers,
> Mark.

XEN_OBJS became:

-XEN_OBJS := xen_backend.o xen_devconfig.o
-XEN_OBJS += xen_console.o xenfb.o xen_disk.o xen_nic.o
-ifdef CONFIG_XEN
-  OBJS += $(XEN_OBJS)
-endif
+obj-$(CONFIG_XEN) += xen_backend.o xen_devconfig.o
+obj-$(CONFIG_XEN) += xen_console.o xenfb.o xen_disk.o xen_nic.o

and

-XEN_OBJS := xen_machine_pv.o xen_domainbuild.o
+obj-$(CONFIG_XEN) += xen_machine_pv.o xen_domainbuild.o
 ifeq ($(CONFIG_XEN), yes)
-  OBJS += $(XEN_OBJS)
   LIBS += $(XEN_LIBS)
 endif

i.e. XEN_OBJS don't exist anymore, what do you mean here?  Remove the
intermediate change?

Later, Juan.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]