[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] build failure on x86, any suggestions?

From: Peter Volkov
Subject: Re: [Qemu-devel] build failure on x86, any suggestions?
Date: Sat, 15 Mar 2008 18:13:02 +0300

В Сбт, 15/03/2008 в 14:20 +0000, Paul Brook пишет:
> On Saturday 15 March 2008, Peter Volkov wrote:
> > Hello.
> >
> > I just wanted to point developers attention to the following bug:
> > bugs.gentoo.org/212351 , comment #11 and further. The problem is that
> > qemu does not compile any more on x86. I've tried recent snapshot
> > (2008-03-15_05) and the problem persist there.
> You're almost certainly using gcc4.x. Don't do that.

Paul, thank you for you answer. I do have gcc-4 installed on my system
but I'm sure that I'm using gcc-3.4:

> gcc --version
gcc (GCC) 3.4.6 (Gentoo 3.4.6-r2 p1.5, ssp-3.4.6-1.0, pie-8.7.10)

As I read FAQ this version should be supported. I've tried to build gcc
without patches (ssp, pie, C++ support and some gentoo specific patches)
but qemu build process still fails at the same place...

> IIRC gentoo already has a big pile hacks for this. This kind of breakage is 
> exactly why those hacks haven't been merged into cvs. They're papering over 
> the problem rather than fixing it, so you should expect them to need constant 
> maintenance.

Sorry, but what hacks are you talking about? The only hack I'm aware
about is that all system is build with newer compiler while to build
qemu I have to install old gcc.

> As mentioned several times on this recently on this list, the proper fix is 
> to 
> finish the TCG conversion. That will happen "when it's done".

Eh, I saw you talking about this and I'm aware that this will definitely
take time. That's why I asked for suggestion...


Attachment: signature.asc
Description: Эта часть сообщения подписана цифровой подписью

reply via email to

[Prev in Thread] Current Thread [Next in Thread]