[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] solved! (was: Re: qemu 20061102 snapshot: trouble booting d

From: Juergen Lock
Subject: [Qemu-devel] solved! (was: Re: qemu 20061102 snapshot: trouble booting directly from cdrom device)
Date: Thu, 14 Dec 2006 19:56:53 +0100
User-agent: Mutt/1.5.11

On Sat, Nov 11, 2006 at 01:58:43PM +0100, I wrote:
> Hi!
>  I got a report yesterday of the win2k cd bsod'ing with an
> INACCESSIBLE_BOOT_DEVICE error when booted directly from the device
> (as opposed to from an iso, which worked.)  I dont have a win2k cd,
> but I tried a KANOTIX-2006-01-RC2 cd (linux livecd), and that, although
> it did boot, said
>       VFS: busy inodes on changed media
> repeatedly.  Does anyone else get something like this on another
> host (I'm on FreeBSD)?  I would like to know if its a FreeBSD
> problem (aio not working properly on the cdrom device?) or something
> to do with qemu itself...

Well I finally found the problem here: READ CAPACITY failed because
somehow the #include that defines DIOCGMEDIASIZE got lost, adding this
patch to block-raw.c fixes it:

Index: qemu/block-raw.c
@@ -51,6 +51,9 @@
 #include <linux/cdrom.h>
 #include <linux/fd.h>
+#ifdef __FreeBSD__
+#include <sys/disk.h>
 //#define DEBUG_FLOPPY
 I'll prepare a port update now...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]