[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] qemu-i386 segfaults when running wine on a x86 CPU?

From: James Supancic
Subject: Re: [Qemu-devel] qemu-i386 segfaults when running wine on a x86 CPU?
Date: Fri, 2 Jun 2006 16:53:51 -0700

But, I am using a version of wine on Linux compiled for Linux? wine is a Linux program is it not?

I got the segfault when I ran
qemu-i386 /usr/bin/wine

when I run file /usr/bin/wine I get
/usr/bin/wine: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.4.1, dynamically linked (uses shared libs), stripped.

I should be able to run 32-bit ELF executable compiled for Intel 80386 CPUs with qemu-i386, shouldn't I?

Note that, I didn't even try to run a Win32 executable with wine, I just tried to run "wine", it should have printed its command line options/help and exited without doing anything strange...

Thank you for your time,
James Supancic

On 5/31/06, Joshua Root <address@hidden> wrote:
James Supancic wrote:
> When I run
> qemu-i386 /usr/bin/wine
> I get
> qemu: uncaught target signal 11 (Segmentation fault) - exiting
> I know I don't need qemu-i386 to run wine compiled for x86 CPUs on an
> x86 CPU. I am trying to figure out how to make a version of wine that
> will work with qemu-i386, after I figure this out I intend to move the
> wine installation over to a sparc CPU.

Qemu's user mode emulation only works for Linux -> Linux at the moment,
i.e. programs compiled for Linux can be run on a Linux host. (The useful
part is of course that programs compiled for a different CPU
architecture than the host's can be run.)

However, encouraging progress has been made on qemu-darwin-user, which
will do what you want to do. See here:

- Josh

reply via email to

[Prev in Thread] Current Thread [Next in Thread]