[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] problem with vvfat and plan9

From: Jens Arm
Subject: Re: [Qemu-devel] problem with vvfat and plan9
Date: Mon, 16 Jan 2006 11:26:24 +0100

> > cannot add sdC1!dos [63,966798) to disk [0,966735): partition boundaries 
> > out of range
> Note that the difference of the larger numbers is exactly 63...
> It might be fixed by replacing the line
>     s->sector_count=0xec04f;
> with
>     s->sector_count=0xec04f - 63;
> in block-vvfat.c, but I can't tell all the implications right now. If you 
> feel lucky, you can try it, but I'll have a look anyway.

I have tested this little fix with plan9 and now it works. I have found no 
e.g. with Linux or so in qemu. Looks like it is working correctly.

Then I have tried to test the :rw: with plan9, but nothing is written into the 
host filesystem.
I have enabled debug in vvfat and there I see that the newly created file in 
plan9 mounted vvfat-drive
is shown in the log. But I do not see the commit message which in the log is 
shown if I try with linux.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]