[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Qemu won't compile on Fedora Core 4/X86_64

From: Paolo Campegiani
Subject: [Qemu-devel] Qemu won't compile on Fedora Core 4/X86_64
Date: Sun, 8 Jan 2006 15:43:48 +0100
User-agent: Internet Messaging Program (IMP) 3.1

Hello guys,

I've tried to compile qemu (version 0.8.0 from website and pulled from CVS) over
a Fedora Core 4 on a X86_64. In both cases, I ran these commands:

configure --cc=gcc32 --host-cc=gcc32

and after lots of warnings about casting to pointer from integer of different
size, I finally ended up with this:

In file included from /home/zefram/Desktop/qemu-0.8.0/translate-op.c:36:
op.h: In function `dyngen_code':
op.h:3759: syntax error before '.' token
op.h:3761: syntax error before '.' token
make[1]: *** [translate-op.o] Error 1
make[1]: Leaving directory `/home/zefram/Desktop/qemu-0.8.0/sparc-user'
make: *** [all] Error 1

what GCC does not like is in the .LC64 here:

case INDEX_op_fnegs: {
    extern void op_fnegs();
extern char .LC64;
    memcpy(gen_code_ptr, (void *)((char *)&op_fnegs+0), 31);
    *(uint32_t *)(gen_code_ptr + 10) = (long)(&.LC64) - (long)(gen_code_ptr +
10) + -4;
    gen_code_ptr += 31;

If I comment these lines, compilation resumes until I get the same error over
sparc-softmmu/op.h. If I "fix" it same way above, compilation terminates with no
other errors.

I can live without sparc emulation, but I was not able to install Windows XP
with this qemu: the I/O seems a lot faster than 0.7.2/x86, but when the guest
operating system restarts I have the splash screen saying to wait, and it does
nothing (CPU usage for qemu is near zero) forever, so it seems to me that there
are more problems than sparc-related.

I'd be more than happy to test and try some fixes if someone will provide them
to me, at least giving me a clue on what to do (I have understood that this
.LC64 is something related to object file, but googling the Internet gave me no
other information and the info gcc pages does not explicit report this symbol
nor a more generic .LC, so I don't know what to search for).

Also: would be possible to provide a _static_ binary for qemu on the site? the
binary for i386 is dynamic and it does not run over a x86_64 system (complaints
about missing libraries).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]