[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Bug compiling kqemu

From: Juergen Bullinger
Subject: [Qemu-devel] Bug compiling kqemu
Date: Sun, 29 May 2005 14:10:01 +0200

Hi all,

sorry if this is already a known problem. I downloaded qemu 0.7.0 and
kqemu 0.6.2-1. First I only compiled qemu 0.7.0 without kqemu on my
machine (which is a AMD Athlon/64 running Fedora Core 3 in the 86_64
Qemu worked fine with Win 98.
Then I tried to compile it a second time with kqemu and got the
following problem:

make[1]: Entering directory
make -C /lib/modules/2.6.11-1.27_FC3/build M=`pwd` modules
make[2]: Entering directory `/lib/modules/2.6.11-1.27_FC3/build'
  CC [M]  /home/juergen/downloads/qemu/qemu-0.7.0/kqemu/kmod.o
cp /home/juergen/downloads/qemu/qemu-0.7.0/kqemu/kqemu-mod-
i386.o /home/juergen/downloads/qemu/qemu-0.7.0/kqemu/kqemu-mod.o
  LD [M]  /home/juergen/downloads/qemu/qemu-0.7.0/kqemu/kqemu.o
ld: Relocatable linking with relocations from format elf32-i386
(/home/juergen/downloads/qemu/qemu-0.7.0/kqemu/kqemu-mod.o) to format
elf64-x86-64 (/home/juergen/downloads/qemu/qemu-0.7.0/kqemu/kqemu.o) is
not supported
make[3]: *** [/home/juergen/downloads/qemu/qemu-0.7.0/kqemu/kqemu.o]
Error 1
make[2]: *** [_module_/home/juergen/downloads/qemu/qemu-0.7.0/kqemu]
Error 2
make[2]: Leaving directory `/lib/modules/2.6.11-1.27_FC3/build'
make[1]: *** [kqemu.ko] Error 2
make[1]: Leaving directory
make: *** [all] Error 2
address@hidden qemu-0.7.0]$

Is this problem already known?
Is there already a workaround?

BTW: qemu is great! Thank you folks! 
When I compiled it I got many warnings about pointer-to-int conversions
which could lead to problems, but it worked fine. I guess it was just,
because my system is 64 bit. If you like to remove these warnings I
could send you the output of the make process.

Thank you in advance


Juergen Bullinger <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]