[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Old DOS under Qemu

From: jeebs
Subject: [Qemu-devel] Old DOS under Qemu
Date: Wed, 11 May 2005 19:26:17 -0500

I've been trying to install various old versions of DOS under Window's v0.70 
of qemu from FreeOSZoo.

And since so few people appear to be using the Windows version, I've been 
making a point to do as much testing as I can, with as wide a variety of 
operating systems as I can find.

>From version 5 on up, I only have a few problems (Which I've already 

However, I got hold of some warez copies of Dos 3.30 (several copies) and 
Dos 4.01.

They don't install.

Running the floppies themselves usually works.

But actually installing them or running off the hard drive causes problems.

Using the command line (as created by qGui):

h:\qemu\qemu\qemu.exe -L "h:\qemu\qemu\bios" -boot a -m 1
-fda "H:\VDisks\OS\warez\Dell330\Dell330-1.720"
-hda "H:\Qemu\OpSys\Dos330.dsk"
-nics 0 -dummy-net -isa -localtime -hdachs 60,16,63,none

Boots the floppy fine.

I can usually format the hard drive fine.  (One version always fails the 

I can read and write to the hard drive fine.

But when it comes time to boot the hard drive, every old version of DOS I've 
tried fails the same way.  With the message:

Booting from hard disk...
Disk boot failure.

I tried 6 versions of old dos (1 v3.2, 4 v3.30 and 1 v4.01)

I even tried the -hdachs option thinking that might help.  (I got the params 
from Bochs, so that should be right.)

I tried enabling and disabling options, such as -isa and -std-vga

None of that helped.

Any ideas?

Considering they do boot from the floppy, and they do work under Bochs 
emulator, I'm kind of figuring it's a problem with the command line. 
(That's why I tried the hdachs option.  It didn't help.)

Considering the problem is reasonably consistant, I'm kind of ruling out 
them being 'warez' copies of DOS, since I got them from several different 
places and they are behaving the same.

But, on the off chance that it's a problem with qemu, I thought I'd post my 
'help!" in the mailing list instead of in the qemu-user's forum, where 
developers probably rarely visit.

So... Any ideas?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]