[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Problems with Windows build 0.70 from FreeOSZoo

From: jeebs
Subject: [Qemu-devel] Problems with Windows build 0.70 from FreeOSZoo
Date: Tue, 3 May 2005 16:56:14 -0500

Now that FreeOSZoo finally has the 0.70 build (and will hopefully do regular 
cvs builds again), I decided to test it.

1) a nonexistant cd image should give an error.  It's easy to make a typo in 
the monitor when doing a 'change cdrom' command.  But qemu just quietly accepts 

2) qemu still can't handle spaces in filenames in the monitor.  Not even quotes 

3) still can't properly do a cd change.  Sometimes the Win98 installer seems to 
lock up, other times it still shows the old cd structure.  (I think what is 
happening is that the 'eject' command is being followed so fast by the new cd 
insertion that the guest OS doesn't always have time to recognize the change.  
Or maybe not.  I'm not a developer so I can't test this.)

4) While booting a dos floppy that had Microsoft Mouse 8.20, the mouse driver 

5) While booting a Norton Ghost boot floppy, the Ghost backup program itself 
segfaulted.  Identical values to the mouse problem above.

6) While installing Dr.Dos 7.03, I had problems when I'd change the floppy 
disk.  At first I thought that it wasn't recognising the floppy, like with 
qemu's cd problem.  But by the fifth floppy, I think it might have been a 
keyboard problem.  It just wasn't recognising the 'enter' key in the notice box 
about changing disks.  If I played with the keyboard enough, it would 
eventually accept the enter key and continue installing.  Also, after booting, 
emm386 does give a warning about the a20 line already being enabled.  But other 
than those things, it seems to work.

Due to the length of installation on my slow computer, I haven't yet tried 
installing XP under qemu.

And yes, I know I've mentioned these many times before.  And I'm going to keep 
mentioning them until they get fixed.  If I don't mention them, people are 
going to forget about it because fixing these bugs aren't "fun", like adding 
new features.

Things that seem to work, although I haven't done extensive testing:

1) FreeDos 0.9sr1.  Including the mouse

2) ms-dos 6.22, including drvspace.

3) Win98 installs.  Didn't do any tests.  The sound is a bit choppy, but that 
could just be due to the speed of qemu on my system.

4) Dr. Dos 6.0  Seems to work.  Gives the same warning about A20 as DrDos 7.03. 
 I didn't have the floppy change problem.

(Also, I'd like to point out that I once mentioned some mouse problems with 
qemu.  Either that was fixed, or my recent reinstall of WinXP solved that 

Feature requests:

1) Mention in the docs that qemu supports 1.2m floppies, in addition to 1.44m.  
Some people might want to know.  I was just about to add that to the feature 
request list when I decided I should actually try it first.

2) Scroll bars for the qemu window.  So we can more easily do large screen 
sizes for OS's that expect it during install.

3) The ability (in the bios?) to prevent a reboot.  Or at least ask the user 
whether to allow the reboot.

4) in the monitor, when you do a 'savevm', remind the user that the image may 
not be valid later unless you first stop the emulator.  To help newbies, plus 
as a reminder to the rest of us.

5) When starting qemu with some invalid parameters, print out a notice saying 
what the problem is, and then (for windows), wait for a key press to give the 
user time to read it before the window disappears.

6) A brief command line summary when qemu is run without arguments or -?, /?, 
help, -help /help

7) in qemu-image, disallow raw images 2g or larger under windows, since that 
doesn't work!  It just produces a zero length file.  Apparently whatever method 
you use to handle files, is limited to just 31 bits.

8) in qemu-image, allow lower case 'm' and 'g' for size modifiers.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]