[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH] EtherBoot and RTEMS works on QEMU

From: Lars Munch
Subject: [Qemu-devel] [PATCH] EtherBoot and RTEMS works on QEMU
Date: Sat, 27 Nov 2004 15:08:57 +0100
User-agent: Mutt/1.5.6+20040907i


The following patch adds EtherBoot and RTEMS to QEMU OS Support web

I am very impressed with QEMU. EtherBoot 3.5.9 and RTEMS 4.6.2 worked
out of the box with network support using ISA-only system (-isa).

The EtherBoot rom was simply made by "make bin/ne.zlilo" and loading
that from a disc image with grub installed. I could not get EtherBoot
to work in PCI mode.

RTEMS 4.6.2 worked by compiling an application for the pc386 target with
an NE2000 NIC on port 0x300 and IRQ 9. This was tested by loading RTEMS
from a disk image with grub and by loading RTEMS using EtherBoot.

I know EtherBoot is not an OS, but I thinks it is important enough
application and should be added to the list anyway.

Please apply.

Lars Munch

Attachment: more-os.patch
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]