[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Re: Downloaded files are corrupt

From: Ronald
Subject: [Qemu-devel] Re: Downloaded files are corrupt
Date: Fri, 19 Nov 2004 00:09:08 +0100
User-agent: Pan/0.14.2 (This is not a psychotic episode. It's a cleansing moment of clarity.)

Le Thu, 18 Nov 2004 23:28:17 +0100, Ronald a écrit :

> Le Thu, 18 Nov 2004 22:45:38 +0100, Magnus Damm a écrit :
>> Have you tried downloading files from the integrated TFTP server
>> included with the -user-net implementation? Does that work out ok?
>> / magnus
> Quick review for (linux host and guest)
> tftp is ok, -redir is ok too (ssh && scp host to guest), streaming works
> (mplayer -ao alsa -vo null, I can
> browse the web, but I get the same corruption downloading files from http
> (tried with links and curl, curl print 'curl: (18) transfer closed with 1
> bytes remaining to read' for
> http://fabrice.bellard.free.fr/qemu/qemu-0.6.1.tar.gz, tar tzf list until
> hw/cuda.c gzip complain about data--crc and data-lenght).

After reboot some (partial) results for windows host too(same guest image
as previously)

C:\Program Files\Qemu>qemu -L .\bios -m 128 -localtime -user-net
-enable-audio -redir tcp:2222::22 -tftp /temp -hda c:\qemu.dsk -boot c

tftp is ok, ssh too but there is some delay between password enter and
getting the shell (~1 minute).
I don't have internet access under windows, so I can't try file
downloading, sorry.
Guest is runnig 2.6 if that matter.

>> On Thu, 2004-11-18 at 22:34, Aaron McDonald wrote:
>>> I'm having a problem downloading files. I'm using qemu 0.6.1 to run
>>> Feather Linux from within Alt Linux on a 800 MHtz machine with 256MB of
>>> RAM.
>>> qemu -hda harddisk -cdrom feather-0.6.1.iso -boot d -m 256
>>> -enable-audio -user-net -localtime
>>> Everything starts up ok but if I download something from the internet,
>>> I don't seem to get the last byte and so the file is corrupt. I have
>>> the same issue with a Damn Small Linux iso.
>>> I can download the file just fine from my host OS (Alt Linux) so I'm
>>> ruling out a network issue. Also, I'm having the same problem when
>>> using Windows 2000 as the host OS on a 2.6 GHtz machine with 1GB of RAM
>>> so I'm thinking that it's not a hardware issue either.
>>> I posted this issue to the bulletin board a couple of days ago. Another
>>> user responded and said that he'd had the same problem w/ qemu >0.6.0
>>> running debian/knoppix under Win XP (host) with "-user-net".
>>> Thanks,
>>> Aaron
>>> _______________________________________________ Qemu-devel mailing list
>>> address@hidden
>>> http://lists.nongnu.org/mailman/listinfo/qemu-devel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]