[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] FreeSBIE-20040919, ffreep insn

From: Fabrice Bellard
Subject: Re: [Qemu-devel] FreeSBIE-20040919, ffreep insn
Date: Wed, 17 Nov 2004 23:00:29 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

I don't think ffreep is used by the software you tried. It must be a bug which yields a jump in a data section. ffreep is not documented and it does not work on every CPU (I get an invalid instruction exception on P4), so I propose not to implement it.


Juergen Lock wrote:
Hi!  I just tried FreeSBIE-20040919,
and got an illegal instruction when starting X.  I gdb'd the core
and found its the ffreep insn that it failed on:
says its undocumented (A.55, does an ffree and then pops st0),
so thats probably the reason why its missing.  So i added it:

Index: qemu/target-i386/translate.c
@@ -3187,6 +3187,10 @@
                     goto illegal_op;
+            case 0x38: /* ffreep sti */
+                gen_op_ffree_STN(opreg);
+                gen_op_fpop();
+ break; case 0x3c: /* df/4 */
                 switch(rm) {
                 case 0:

and now X gets a bit further but then gets another illegal instruction,
this time with a signal handler setup so i dont know the failed eip.
(I guess i'd have to patch X to get it...)  But, later i started an xterm
(displaying on the host), and that came up but then also died of an
illegal instruction, this time it was xorps  %xmm0,%xmm0.  So i guess
this FreeSBIE's X is built with -march=pentium3 or something.
(What are the chances of adding sse to qemu?  I guess slim :)

 Anyway, I guess there's nothing wrong with adding ffreep...

Qemu-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]