[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] BeOS/Zeta eats 100% cpu time

From: André Braga
Subject: Re: [Qemu-devel] BeOS/Zeta eats 100% cpu time
Date: Thu, 30 Sep 2004 12:36:25 -0300

That one is simple: you're booting in either monochrome or VESA mode,
because there's no native accelerated driver for the videocard QEMU
emulates, and BeOS does indeed use 100% CPU in this case. I don't know
what are the details under the hood, but this is a known fact.

You could try compiling QEMU with MingW instead of cygwin, as it
should work out of the box and the toolchain setup is not as
complicated or lenghty.


"Dealing with failure is easy: Work hard to improve. Success is also
easy to handle: You've solved the wrong problem. Work hard to improve"
Alan J. Perlis

On Thu, 30 Sep 2004 15:32:22 +0200, Christian Wiese <address@hidden> wrote:
> Hello list,
> hope this is the right place to tell you the behaviour of qEmu running
> BeOS. If not, please ignore it ;-)
> So I finally got BeOS (Zeta) installed (longer story ;-)) and it works,
> but only very slow. The strange thing is, that it uses the 100% of my
> host cpu all the time. The HLT instruction is used by BeOS btw.
> So I would like to test where (and why) this is happening. I tried to
> compile with cygwin, but I didn´t get it (and I would not like to 'mess'
> my system with another "gnu-emulation-suite"). And even if I get it, I
> wouldn´t really know where to search.
> So maybe someone got an idea and we can find the problem together :-)
> Greetings,
>  Chris

reply via email to

[Prev in Thread] Current Thread [Next in Thread]