[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] problems running qemu-arm under Fedora Core 2.

From: Lennert Buytenhek
Subject: [Qemu-devel] problems running qemu-arm under Fedora Core 2.
Date: Fri, 3 Sep 2004 16:49:29 +0200
User-agent: Mutt/1.4.1i

Hi all,

qemu (http://www.bellard.org/qemu) is a "FAST! processor emulator
using dynamic translation to achieve good emulation speed", according
to its web site.

qemu contains a program called 'qemu-arm', which will let you run
ARM binaries under an x86 or any other linux host.  This program
works fine most of the time, but it doesn't quite work very well
with Fedora 2 and its kernels.

First of all, I need 'setarch i686' to get qemu-arm to run at all
under Fedora 2.  Second, since the 2.6.7-1.494.2.2 kernel update,
qemu doesn't work anymore even when using setarch.

Has anyone else seen this?  Any idea where I should look?


----- Forwarded message from Lennert Buytenhek <buytenh> -----

Date: Fri, 3 Sep 2004 16:42:23 +0200
From: Lennert Buytenhek <buytenh>
To: address@hidden, address@hidden
Subject: Re: cause found for qemu-arm problems on fedora 2 (Re: [Qemu-devel] 
Problem with running machine code specified in the program)
In-Reply-To: <address@hidden>
User-Agent: Mutt/1.4.1i

On Fri, Sep 03, 2004 at 03:34:00PM +0200, Lennert Buytenhek wrote:

> > I got "qemu: uncaught target signal 11 (Segmentation fault) - exiting" when
> > running program like that:
> I was running into this too, and just checked it out.  You should do:
> 1. Run 'setarch i686 qemu-arm' instead of 'qemu-arm'.
> 2. Downgrade to the original 2.6.5 kernel that came with FC2.
> It seems that qemu-arm broke somewhere between fedora's version of
> 2.6.6 and 2.6.8, their current kernel.  I'm trying the intermediate
> releases right now.

OK, here are my findings.

I tried qemu-arm from qemu 0.5.5 and from all daily qemu CVS snapshots
between 20040504 and 20040901.  Of those, there are actually only 16
different qemu-arm binaries (with a distinct md5 sum), so I only used

I tried the Fedora Core 2 kernels 2.6.5-1.358 (original), 2.6.6-1.427,
2.6.6-1.435, 2.6.6-1.435.2.1, 2.6.6-1.435.2.3, 2.6.7-1.494.2.2 and
2.6.8-1.521 (the latest.)

On all kernels, you get a sig11 if you run without 'setarch i686'.

If you run with 'setarch i686', kernel 2.6.6-1.435.2.3 still runs
everything fine, but 2.6.7-1.494.2.2 breaks all qemu versions except
for the 20040519 CVS snapshot.  And on the kernel after that,
2.6.8-1.521, all qemu versions are broken.  If I then try to set
vm.legacy_vm_layout to 1, 20040519 starts working again, but all
other snapshots before and after remain broken.



----- End forwarded message -----

reply via email to

[Prev in Thread] Current Thread [Next in Thread]