[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: /dev/tun Was: Re: [Qemu-devel] Win98: how to exchange data with Linu

From: Joe Menola
Subject: Re: /dev/tun Was: Re: [Qemu-devel] Win98: how to exchange data with Linux
Date: Thu, 15 Jul 2004 20:01:23 -0500
User-agent: KMail/1.6.2

On Wed July 14 2004 9:49 pm, Jim C. Brown wrote:
> On Wed, Jul 14, 2004 at 09:10:01PM -0500, Joe Menola wrote:
> > I'm baaaaaaaaaack. :)
> >
> > I started playing with vbe, I think I've made some progress but can't
> > seem to get things working. It's possible that I'm in over my head....
> > I'll let you be the judge.
> > Here's where I'm at:
> >
> > As root:
> > address@hidden vde-1.5.3]# ./vde_switch -tap tap0 -daemon
> > address@hidden vde-1.5.3]# ifconfig tap0
> > address@hidden vde-1.5.3]# chmod 777 /tmp/vde.ctl
> > address@hidden vde-1.5.3]# echo "1" > /proc/sys/net/ipv4/ip_forward
> > address@hidden vde-1.5.3]#  iptables -t nat -A POSTROUTING -o eth0 -j
> >
> > I assume that at this point vde is set and ready.... or have I already
> > fallen off the edge?
> The tap0 device should have its own subnet. E.g. below, it appears that
> your LAN already uses the 192.168.0.* subnet. I'd recommend that you use
> this
> ifconfig instead:
> > address@hidden vde-1.5.3]# ifconfig tap0 netmask 
> >

> I don't know iptables very well, but to the best of my knowledge that looks
> correct. You can try adding this line as well, not sure if it will help or
> not however:
> > address@hidden vde-1.5.3]#  iptables -t nat -A POSTROUTING -o tap0 -j

Tried both tap0 and eth0, also each seperately, no difference seen.

> (note to self: add iptables guru to vde team)
> > As user I start qemu with
> >
> > address@hidden qemu]$ vdeq qemu  -hda /mymnt/qemu/qdrive.img  -boot c -m 256
> > -enable-audio -pci -cirrusvga
> >
> > Monitor output
> >
> > QEMU 0.5.5 monitor - type 'help' for more information
> > (qemu) qemu exited: vdeq quits
> > address@hidden qemu]$
> That looks right, unless you are saying that qemu quits prematurely.

No, that was output from a completed and closed Qemu session.

> > I'm somewhat confused about network settings for Win98, my "real" network
> > consists of my linux host (eth0) connected to a dsl router (
> > I tried dchp (my router supports it but it's not installed on my linux
> > host), tried static ip's (address assinged to tap0?) and
> > (unused address on my lan) . As gateway's I have both my
> > routers address and eth0's address on my Linux host. Same for dns.
> > No internet, and cannot ping anything.
> >
> > Is there hope? lol
> DHCP from the router will not work. Assuming that you've made the above
> change and are using the 192.168.254.* subnet, the router/gateway for Win98
> is and you can assign it any ip address you want in the
> subnet, for example should work. You can also do
> /sbin/dhcpd tap0
> after you set up vde and install a DHCPd server. That works great for me.
> (I can give you my dhcpd.conf file if you decide to go this route.)

Please do. I've installed a DHCPd server, I doubt that I have dhcpd.conf setup 

Thanks again for all your help. I've been keeping a log of my efforts, if I 
get this up and going I could easily put together a cut n paste trail of all 
my steps. You might be able to use it as a rough draft for your up coming 
"VBE For Dumbies" book?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]