[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Win98 network & cirrus logic success

From: Johannes Schindelin
Subject: [Qemu-devel] Win98 network & cirrus logic success
Date: Thu, 15 Jul 2004 12:03:47 +0200 (CEST)


short warning at first: don't ping. It does not do what you think it does.
Try looking at a web page instead.

After long hours and nights, I finally got Win98 working as it should.
However, it was not easy: first of all, I forgot to update the rom images
in /usr/local/share/qemu. This resulted in several crashes. Even after
that, I had plenty of crashes, the network card would not be recognized,
and it was generally very frustrating. I then played with the device
manager and kept removing devices (especially that APM device...). A few
times Win98 then would "recognize" devices with very strange names (all
characters > 0x80 ASCII), which I removed at once. A few times the host
bridge was installed. At one time, the IDE controller was defunct, so
Win98 could not detect the cdrom. After that, however, things became much
more stable. Win98 recognized everything just fine. It forgot the HiColor
setting a couple of times, but then it worked. Without crashing.

Next came the network. I tried to ping, and it wouldn't. ipconfig showed
no 169.* rubbish, but the expected 10.* address. I now think the ping
fails, because the answer is not correctly routed back, being ICMP instead
of TCP. When I finally had that idea and just tried to surf to
www.google.de, it just worked...

In hindsight, I think it would have been easier to just reinstall
Windows98: The original installation was before cirrus logic and pci were
present in qemu.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]