[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] openbsd image on freeoszoo

From: Jim C. Brown
Subject: [Qemu-devel] openbsd image on freeoszoo
Date: Fri, 9 Jul 2004 19:18:09 -0400
User-agent: Mutt/1.4i

My apologies but I don't have the email address of the FreeOSZoo
maintainer. I merely want to make some comments that might help make

For the openbsd image, I find that it is necessary to disable DMA for
the pciide device (using flag 0x0fcc). Otherwise it is only possible to
boot into ISA mode.

Also, (at least for ISA mode - havent tried using apm in PCI mode yet)
I have to disable the apm0 device or else I get lots of "Error - Unknown
result - 83" messages spamming my screen. (This is not verbatim btw, only
from my bad memory.)

I also get lots of "remote transmit DMA failed to complete" errors, for
both the ISA and the PCI nic. I haven't solved this one yet but it seems
harmless. (For the ISA nic, it seems that it MUST be called ne2 btw or network
won't work.) For the PCI nic, I also get "send_packet: Input/output error",
not solved yet either.

None of these problems appear on the NetBSD image.

For the OpenBSD ISA nic, it seems to ignore the -macaddr parameter???
PCI nic does the right thing. (NetBSD's PCI nic also seems to ignore this, tho
I haven't tried to pass it manually yet).

For both images, it might be a good idea to set it up to use dhcp by default,
instead of hardcoding a network address.

For the most part, I have been very happy with the openbsd image ... it is
great for hacking on. :)

Infinite complexity begets infinite beauty.
Infinite precision begets infinite perfection.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]