[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] powerpc (debian/sid) woes

From: Fabrice Bellard
Subject: Re: [Qemu-devel] powerpc (debian/sid) woes
Date: Tue, 29 Jul 2003 22:57:14 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.1) Gecko/20020828

The problem is that I don't have access to a gcc-3.3 powerpc based system...


Christof Petig wrote:

Since 0.1.6 I encountered occasional compile/link failures and various errors on powerpc. Since I thought them to be temporary I did not spend much thought about it and waited for a new (and working version). But looking more closely these problems seem to persist ...

Intermediate problems:
since 2003-5-27 18:50:  dyngen: could not find .sdata section

but since 2003-5-30 18:50 (and up to current CVS):
The process loops forever (gcc-3.3,-O2) or encounters an illegal instruction (gcc-3.3, -O0).

Since debian shipped more actual kernel headers with glibc, I am no more able to try gcc-2.95 (gcc-3.2 fails like gcc-3.3):

syscall.c: In function `_llseek':
syscall.c:95: more than 10 operands in `asm'

(looks nonsense to me)

But in any case I would like to have 3.3 working.

Offending code attached.

But what is even nagging me more is the fact that I don't have a working newer wine than the one you offer for download. I tried to download .debs from unstable, as of 2003-4-11 it's ls worked. Since 0.1.6 it segfaults.

Has anybody had any recent success with powerpc, a recent wine, a recent compiler and a recent glibc? ;-)


Working (0.1.6)
0x300a9990:  pushl  %esp
0x300a9991:  call   0x0

0x0000: movl_T0_ESP
0x0001: pushl_T0
0x0002: movl_T0_im 0x300a9996
0x0003: pushl_T0
0x0004: jmp_im 0x300a99e8
0x0005: end

OUT: [size=52]
0x60292600:  mr r24,r20
0x60292604:  addi       r9,r20,-4
0x60292608:  stwbrx     r24,r0,r9
0x6029260c:  mr r20,r9
0x60292610:  lis        r9,12299
0x60292614:  addi       r24,r9,-26218
0x60292618:  addi       r9,r20,-4
0x6029261c:  stwbrx     r24,r0,r9
0x60292620:  mr r20,r9
0x60292624:  lis        r9,12299
0x60292628:  addi       r9,r9,-26136
0x6029262c:  stw        r9,32(r27)
0x60292630:  blr

Failing (current CVS):
0x0000: movl_T0_ESP
0x0001: pushl_T0
0x0002: movl_T0_im 0x300a9996
0x0003: pushl_T0
0x0004: jmp_tb_next 0x601958f0 0x300a99e8
0x0005: end

OUT: [size=64]
0x603358f0:  mr r24,r20
0x603358f4:  addi       r9,r20,-4
0x603358f8:  stwbrx     r24,r0,r9
0x603358fc:  mr r20,r9
0x60335900:  lis        r9,12299
0x60335904:  addi       r24,r9,-26218
0x60335908:  addi       r9,r20,-4
0x6033590c:  stwbrx     r24,r0,r9
0x60335910:  mr r20,r9
0x60335914:  b  6045EEDC        <<< strange?
0x60335918:  lis        r11,24601
0x6033591c:  lis        r9,12299
0x60335920:  addi       r24,r11,22768
0x60335924:  addi       r9,r9,-26136
0x60335928:  stw        r9,32(r27)
0x6033592c:  blr

Qemu-devel mailing list


reply via email to

[Prev in Thread] Current Thread [Next in Thread]