[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-block] [Qemu-devel] [PATCH] iotests: Require Python 3.5 or lat
Re: [Qemu-block] [Qemu-devel] [PATCH] iotests: Require Python 3.5 or later
Thu, 19 Sep 2019 10:35:30 +0200
Am 18.09.2019 um 20:49 hat John Snow geschrieben:
> On 9/18/19 4:55 AM, Kevin Wolf wrote:
> > Running iotests is not required to build QEMU, so we can have stricter
> > version requirements for Python here and can make use of new features
> > and drop compatibility code earlier.
> > This makes qemu-iotests skip all Python tests if a Python version before
> > 3.5 is used for the build.
> > Suggested-by: Eduardo Habkost <address@hidden>
> > Signed-off-by: Kevin Wolf <address@hidden>
> > ---
> > tests/qemu-iotests/check | 14 +++++++++++++-
> > 1 file changed, 13 insertions(+), 1 deletion(-)
> > diff --git a/tests/qemu-iotests/check b/tests/qemu-iotests/check
> > index 875399d79f..a68f414d6c 100755
> > --- a/tests/qemu-iotests/check
> > +++ b/tests/qemu-iotests/check
> > @@ -633,6 +633,13 @@ then
> > export SOCKET_SCM_HELPER="$build_iotests/socket_scm_helper"
> > fi
> > +# Note that if the Python conditional here evaluates True we will exit
> > +# with status 1 which is a shell 'false' value.
> > +python_usable=false
> > +if ! $PYTHON -c 'import sys; sys.exit(sys.version_info >= (3,5))'; then
> > + python_usable=true
> > +fi
> > +
> Do we want this as a temporary fix only until we can stipulate the same
> version in the configure file?
I thought that maybe we should leave the code around so that at some
later point, we could upgrade it to 3.6 (or something else) before QEMU
as a whole does so.
In fact... Could we already require 3.6 now instead of using 3.5, which
I think we only chose because of Debian Stretch (oldstable)?