qemu-block
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-block] [PATCH v2] nvme: Make nvme_init error handling code more re


From: Fam Zheng
Subject: [Qemu-block] [PATCH v2] nvme: Make nvme_init error handling code more readable
Date: Mon, 21 May 2018 16:58:34 +0800

Coverity doesn't like the tests under fail label (report CID 1385847).
Reset the fields so the clean up order is more apparent.

Signed-off-by: Fam Zheng <address@hidden>

---

v2: Don't play stupid. [Peter]
---
 block/nvme.c | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/block/nvme.c b/block/nvme.c
index 6f71122bf5..c2eb9e2a4e 100644
--- a/block/nvme.c
+++ b/block/nvme.c
@@ -566,6 +566,10 @@ static int nvme_init(BlockDriverState *bs, const char 
*device, int namespace,
         return ret;
     }
 
+    /* Fields we've not touched should be zero-initialized by block layer
+     * already, but reset it anyway to make the error handling code easier to
+     * reason. */
+    s->regs = NULL;
     s->vfio = qemu_vfio_open_pci(device, errp);
     if (!s->vfio) {
         ret = -EINVAL;
-- 
2.14.3




reply via email to

[Prev in Thread] Current Thread [Next in Thread]