[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-block] [Qemu-devel] [PATCH] qemu-img: don't shadow opts variab
From: |
Max Reitz |
Subject: |
Re: [Qemu-block] [Qemu-devel] [PATCH] qemu-img: don't shadow opts variable in img_dd() |
Date: |
Mon, 19 Jun 2017 17:18:18 +0200 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.1.0 |
On 2017-06-19 17:00, Stefan Hajnoczi wrote:
> It's confusing when two different variables have the same name in one
> function.
>
> Cc: Reda Sallahi <address@hidden>
> Signed-off-by: Stefan Hajnoczi <address@hidden>
> ---
> qemu-img.c | 9 +++------
> 1 file changed, 3 insertions(+), 6 deletions(-)
>
> diff --git a/qemu-img.c b/qemu-img.c
> index 0ad698d..c285c2f 100644
> --- a/qemu-img.c
> +++ b/qemu-img.c
> @@ -4249,15 +4249,12 @@ static int img_dd(int argc, char **argv)
> case 'U':
> force_share = true;
> break;
> - case OPTION_OBJECT: {
> - QemuOpts *opts;
> - opts = qemu_opts_parse_noisily(&qemu_object_opts,
> - optarg, true);
> - if (!opts) {
> + case OPTION_OBJECT:
> + if (!qemu_opts_parse_noisily(&qemu_object_opts, optarg, true)) {
> ret = -1;
> goto out;
> }
> - } break;
> + break;
> case OPTION_IMAGE_OPTS:
> image_opts = true;
> break;
Hm, I basically reverted such a style in commit
3258b91141090b05edcaab8f1d1dd355ca91b49a. I find it confusing to use the
same variable for two different things.
I agree that shadowing is bad, though. How about just renaming this
variable here?
Max
signature.asc
Description: OpenPGP digital signature