[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-block] [PATCH 04/24] qapi: qobject input visitor variant for u

From: Kevin Wolf
Subject: Re: [Qemu-block] [PATCH 04/24] qapi: qobject input visitor variant for use with keyval_parse()
Date: Tue, 28 Feb 2017 17:03:28 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

Am 27.02.2017 um 12:20 hat Markus Armbruster geschrieben:
> From: "Daniel P. Berrange" <address@hidden>
> Currently the QObjectInputVisitor assumes that all scalar values are
> directly represented as the final types declared by the thing being
> visited. i.e. it assumes an 'int' is using QInt, and a 'bool' is using
> QBool, etc.  This is good when QObjectInputVisitor is fed a QObject
> that came from a JSON document on the QMP monitor, as it will strictly
> validate correctness.
> To allow QObjectInputVisitor to be reused for visiting a QObject
> originating from keyval_parse(), an alternative mode is needed where
> all the scalars types are represented as QString and converted on the
> fly to the final desired type.
> Signed-off-by: Daniel P. Berrange <address@hidden>
> Message-Id: <address@hidden>
> Rebased, conflicts resolved, commit message updated to refer to
> keyval_parse().  autocast replaced by keyval in identifiers,
> noautocast replaced by fail in tests.
> Fix qobject_input_type_uint64_keyval() not to reject '-', for QemuOpts
> compatibility: replace parse_uint_full() by open-coded
> parse_option_number().  The next commit will add suitable tests.
> Leave out the fancy ERANGE error reporting for now, but add a TODO
> comment.  Add it qobject_input_type_int64_keyval() and
> qobject_input_type_number_keyval(), too.
> Open code parse_option_bool() and parse_option_size() so we have to
> call qobject_input_get_name() only when actually needed.  Again, leave
> out ERANGE error reporting for now.
> QAPI/QMP downstream extension prefixes __RFQDN_ don't work, because
> keyval_parse() splits them at '.'.  Add a TODO comment there.
> qobject_input_type_int64_keyval(), qobject_input_type_uint64_keyval(),
> qobject_input_type_number_keyval() tweaked for style.
> Signed-off-by: Markus Armbruster <address@hidden>

Reviewed-by: Kevin Wolf <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]