qemu-arm
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v4 7/7] tests/boot_linux_console: Tag Emcraft Smartfusion2 as


From: Wainer dos Santos Moschetta
Subject: Re: [PATCH v4 7/7] tests/boot_linux_console: Tag Emcraft Smartfusion2 as running 'u-boot'
Date: Tue, 28 Jan 2020 18:23:18 -0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.4.0


On 1/27/20 2:05 PM, Thomas Huth wrote:
On 21/01/2020 00.51, Philippe Mathieu-Daudé wrote:
Avocado tags are handy to automatically select tests matching
the tags. Since this test also runs U-Boot, tag it.

We can run all the tests using U-Boot as once with:

   $ avocado --show=app run -t u-boot tests/acceptance/
   JOB LOG    : avocado/job-results/job-2020-01-21T00.16-ee9344e/job.log
    (1/3) 
tests/acceptance/boot_linux_console.py:BootLinuxConsole.test_arm_emcraft_sf2: 
PASS (16.59 s)
    (2/3) 
tests/acceptance/boot_linux_console.py:BootLinuxConsole.test_arm_raspi2_uboot: 
PASS (0.47 s)
    (3/3) 
tests/acceptance/boot_linux_console.py:BootLinuxConsole.test_aarch64_raspi3_uboot:
 PASS (2.43 s)
   RESULTS    : PASS 3 | ERROR 0 | FAIL 0 | SKIP 0 | WARN 0 | INTERRUPT 0 | 
CANCEL 0
   JOB TIME   : 19.78 s

Signed-off-by: Philippe Mathieu-Daudé <address@hidden>
---
  tests/acceptance/boot_linux_console.py | 1 +
  1 file changed, 1 insertion(+)

diff --git a/tests/acceptance/boot_linux_console.py 
b/tests/acceptance/boot_linux_console.py
index 22b360118d..4a4cf9d0ea 100644
--- a/tests/acceptance/boot_linux_console.py
+++ b/tests/acceptance/boot_linux_console.py
@@ -305,6 +305,7 @@ class BootLinuxConsole(Test):
          :avocado: tags=arch:arm
          :avocado: tags=machine:emcraft-sf2
          :avocado: tags=endian:little
+        :avocado: tags=u-boot
          """
          uboot_url = ('https://raw.githubusercontent.com/'
                       'Subbaraya-Sundeep/qemu-test-binaries/'

We should maybe move that test to another file, too, since it is not
using Linux. Or should we maybe rename boot_linux_console.py to simply
boot_console.py ?

Thinking aloud: maybe create a directory 'boot' (or 'boot_tests') and group tests in files according to the 'arch' tag.

Example:

[wainersm@localhost boot]$ tree
.
└── arm.py

0 directories, 1 file
[wainersm@localhost boot]$ cat arm.py
from avocado_qemu import Test

class BootArmTest(Test):
    """
    :avocado: tags=arch:arm
    """
    def test_linux_virt()
        """
        :avocado: tags=machine:virt
        :avocado: tags=linux-boot
        """
        # Test here
        pass

    def test_uboot_emcraft_sf2()
        """
        :avocado: tags=machine:emcraft-sf2
        :avocado: tags=endian:little
        :avocado: tags=u-boot
        """
        # Test here
        pass
--------------


Back to this patch...

Reviewed-by: Wainer dos Santos Moschetta <address@hidden>



  Thomas






reply via email to

[Prev in Thread] Current Thread [Next in Thread]