qemu-arm
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-arm] [PATCH v4 1/9] softfloat: Implement run-time-configurable


From: Aleksandar Markovic
Subject: Re: [Qemu-arm] [PATCH v4 1/9] softfloat: Implement run-time-configurable meaning of signaling NaN bit
Date: Sun, 17 Apr 2016 18:21:40 +0000

Hi, Leon,

I cannot say thank you enough for all your valuable feedback.

Just wanted to give you a heads up that in the next version of this patch 
series (planned for tomorrow (Monday) or the day after tomorrow), I am going to 
integrate all your suggestions from this thread, including name "status" 
instead of "fst", and also following segment in cpu.h:

/* op_helper.c */
uint32_t float_class_s(uint32_t arg, float_status *fst);
uint64_t float_class_d(uint64_t arg, float_status *fst);

(unless you tell me not to do so)

Also, I think there will be some improvements in the patch related to 
<CEIL|CVT|FLOOR|...>, that are currently being analysed and tested here.

Sincerely,
Aleksandar
________________________________________
From: Aleksandar Markovic
Sent: Friday, April 15, 2016 4:38 AM
To: Leon Alrae; Aleksandar Markovic; address@hidden
Cc: address@hidden; address@hidden; address@hidden; address@hidden; 
address@hidden; address@hidden; address@hidden; address@hidden; Petar 
Jovanovic; address@hidden; Miodrag Dinic; address@hidden; address@hidden; 
address@hidden; address@hidden; address@hidden; Maciej Rozycki
Subject: RE: [PATCH v4 1/9] softfloat: Implement run-time-configurable meaning 
of signaling NaN bit

Hi, Leon,

There is one more subtle point here. The question is: Where to put declarations 
of two new functions? This is a new case in the organization of mips-specific 
source code files. File helpers.h does not seem to be a good place, cpu.h - 
maybe, but still looks clumsy to me.

IMHO, my solution from earlier versions of this patch series, in spite of 
containing code duplication, is superior in the sense of keeping current 
mips-specific source code file relations intact, respecting autonomy of 
msa_helpers.c, and is the best overall.

Yours,
Aleksandar

________________________________________
From: Leon Alrae
Sent: Friday, April 15, 2016 3:41 AM
To: Aleksandar Markovic; Aleksandar Markovic; address@hidden
Cc: address@hidden; address@hidden; address@hidden; address@hidden; 
address@hidden; address@hidden; address@hidden; address@hidden; Petar 
Jovanovic; address@hidden; Miodrag Dinic; address@hidden; address@hidden; 
address@hidden; address@hidden; address@hidden; Maciej Rozycki
Subject: Re: [PATCH v4 1/9] softfloat: Implement run-time-configurable meaning 
of signaling NaN bit

On 15/04/16 09:48, Aleksandar Markovic wrote:
> Agreed. This looks much better, and is simpler and faster. Though, it looks 
> to me that "fst" should be called "status" instead (just not to break 
> consistency throughout SoftFloat library and in other places of assigning 
> name "status" to the last argument of any function if its type is 
> float_status*). If you agree, I am going to replace name "fst" with name 
> "status" in the code that you provided, otherwise as-is.

Yes, "status" will be fine.

Leon


reply via email to

[Prev in Thread] Current Thread [Next in Thread]