pspp-users
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Various Problems With Latest PSPP Version (For Alan Mead)


From: Ricardo Mejias
Subject: Various Problems With Latest PSPP Version (For Alan Mead)
Date: Wed, 27 Sep 2023 19:58:35 +0000

Read my answers below:


From: pspp-users-bounces+ricardomejias=hotmail.com@gnu.org <pspp-users-bounces+ricardomejias=hotmail.com@gnu.org> on behalf of pspp-users-request@gnu.org <pspp-users-request@gnu.org>
Sent: Wednesday, September 27, 2023 1:47 PM
To: pspp-users@gnu.org <pspp-users@gnu.org>
Subject: Pspp-users Digest, Vol 206, Issue 26
 
Send Pspp-users mailing list submissions to
        pspp-users@gnu.org

To subscribe or unsubscribe via the World Wide Web, visit
        https://lists.gnu.org/mailman/listinfo/pspp-users
or, via email, send a message with subject or body 'help' to
        pspp-users-request@gnu.org

You can reach the person managing the list at
        pspp-users-owner@gnu.org

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Pspp-users digest..."


Today's Topics:

   1. Re: Various Problems With Latest PSPP Version (Alan Mead)


----------------------------------------------------------------------

Message: 1
Date: Wed, 27 Sep 2023 13:47:08 -0400
From: Alan Mead <amead2@alanmead.org>
To: pspp-users@gnu.org
Subject: Re: Various Problems With Latest PSPP Version
Message-ID: <94bcb298-2fa5-51c9-b3dc-64ca9a6aa625@alanmead.org>
Content-Type: text/plain; charset="utf-8"; Format="flowed"

Ricardo,


Sorry to hear you're having such problems. This looks like a serious
error and you should file a bug. I don't know if your dataset is
publicly available, but ideally you would include the dataset and the
PSPP syntax that generated the error. If the developers cannot replicate
your bug, then they cannot see what's wrong nor test their fixes.

Since I sent this email, I have discovered that the data set calculated by my PSPP code is correct .  The problem is exclusively related to running the Descriptive. Each time I run the code first, open the file from the disk and then run the Descriptive, on the same correct data set, it comes up with different numbers. You should try to run a Descriptive on any data set to test this.  The data set is missing many records only when the Descriptive is run together with the rest of the code.

If I had to guess, and it's just a guess, the size of your dataset may
be part of the issue.

I have been running this program for many months with a data set whose size that has not changed much.  This problem started when I first used the latest version of PSPP. 

Does that C++ assertion error happen every time? I wouldn't ignore it.
An assertion is code added to the program in an impossible place.
Ignoring it seems like it would lead to random results, which is what
you see.

The C++ assertion error has not shown up again after three additional runs of the Descriptive, with the data set open.  However, when this error message happened, I was running the Descriptive together with and at the end of the code.  In that situation, the data set on the screen was filled with ???.  Then I opened the file on the disk and it had all the correct data that was supposed to be there. For the next three tests, I just opened the file on the disk and ran the Descriptive.  In those three cases there was no error message, just wrong numbers on the Descriptive.

I just ran the code and the Descriptive together again and this time, I did not get the ???, but large numbers of records were missing and the Descriptives were wrong again.

Also, dumb question maybe, but does this happen always right after a
fresh reboot?

I have not done a reboot of my computer since this started happening.  However, I have exited PSPP entirely and started again, and the problem continued.  

Although it's always good advice to use the latest version, if you
experience new bugs (as you seem to be), then it's a common practice to
go back to a previous version that worked better.

How do I go back to the previous version?  I asked this question before but got no answer.

In your case, I might also be tempted to calculate some of these
descriptive statistics using simpler tools like a spreadsheet so you
have a better idea what the reality of your dataset is.

The data set is too large for a spreadsheet.  It has about 14 million records.


-Alan



On 9/26/2023 9:05 AM, Ricardo Mejias wrote:
> At your suggestion, I upgraded to the lates version of PSPP:
> 1.6.2-g78a33a, on Windows.  But I also deleted my previous version,
> which Ibelieve was [cid:939b582a-d8bb-457f-9894-6cb4832b4c7e] (from a
> previous email I sent you).  I ran some regressions and everything
> went fine.  But then I ran a fairly lengthy code that I have not
> changed since the last month I ran it, to create a report, and these
> very strange things happened:
> The data table showing up on the screen was filled with ??? on all
> cells.  Sample:
>
> The Output does not show any errors.
> The file that was saved had the generally expected numbers on it when
> I opened it.
> Then I ran a DESCRITPIVES
> SET FORMAT COMMA16.4                                                                  
> DESCRIPTIVES  
>       
>       
>       
>       
>       
>       
>       
>       
>       
> STATISTICS SUM MEAN   
>       
>       
>       
>       
>       
>       
>       
>       
> /VARIABLES = SelectedFields_20230912 VoterIDParty_20230808 REP DEM NPA
> LPF OTH Aug2023EftReg Aug2023EftDeReg Aug2023LPFEftReg
> Aug2023LPFEftDeReg REPtoLPF DEMtoLPF NPAtoLPF OTHtoLPF LPFtoREP
> LPFtoDEM LPFtoNPA LPFtoOTH Active Inactive BlankStatus ActiveLPF
> InactiveLPF BlankStatusLPF Aug2023EftRegAge Aug2023LPFEftRegAge
> Aug2023MGender Aug2023FGender Aug2023UGender Aug2023BGender
> Aug2023EftRegMGender Aug2023EftRegFGender Aug2023EftRegUGender
> Aug2023EftRegBGender Aug2023LPFEftRegMGender Aug2023LPFEftRegFGender
> Aug2023LPFEftRegUGender Aug2023LPFEftRegBGender
>
>
>  and got this error message floating over the Output:
>
> I clicked Ignore
>
> The descriptive was produced, but the numbers where completely out of
> line with the previous month by factors of between 0.5 and 5 times.
> This is voter registration data that simple does not change much from
> month to month.
>
> I ran the DESCRIPTIVE again and this time the above error message did
> not show up, but the numbers on the DESCRIPTIVE were still wrong.
>
> I am sure that I was using the exact same code with both PSPP
> versions.  You may be able to fix this.  But meanwhile, how can I get
> back the old version I had to be able to run this report on it?
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.gnu.org/archive/html/pspp-users/attachments/20230927/0a85ddc2/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Outlook-0rf3nmjz.png
Type: image/png
Size: 5443 bytes
Desc: not available
URL: <https://lists.gnu.org/archive/html/pspp-users/attachments/20230927/0a85ddc2/attachment.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image.png
Type: image/png
Size: 169716 bytes
Desc: not available
URL: <https://lists.gnu.org/archive/html/pspp-users/attachments/20230927/0a85ddc2/attachment-0001.png>

------------------------------

Subject: Digest Footer

_______________________________________________
Pspp-users mailing list
Pspp-users@gnu.org
https://lists.gnu.org/mailman/listinfo/pspp-users


------------------------------

End of Pspp-users Digest, Vol 206, Issue 26
*******************************************

reply via email to

[Prev in Thread] Current Thread [Next in Thread]